# Problem with server start up

**URL:** https://community.stardog.com/t/problem-with-server-start-up/3171
**Category:** Support
**Created:** [August 2, 2021, 10:02am UTC](https://community.stardog.com/t/problem-with-server-start-up/3171 "2021-08-02T10:02:52Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![mereolog](https://avatars.discourse-cdn.com/v4/letter/m/ebca7d/32.png) [@mereolog](https://community.stardog.com/u/mereolog)
#### Post date: [August 2, 2021, 10:02am UTC](https://community.stardog.com/t/problem-with-server-start-up/3171/1 "2021-08-02T10:02:53Z")

</div>

I successfully installed the latest Stardog Free platform on my Mac (macOs 11.4).  
Then I set up $STARDOG\_HOME and copied the license file there

But when I tried to run: $ stardog-admin server start  
I got this error:

```auto
Unrecognized VM option 'UseParallelOldGC'
Did you mean '(+/-)UseParallelGC'? Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

```

Btw., here are my Java installation details:  
java 16.0.1 2021-04-20  
Java(TM) SE Runtime Environment (build 16.0.1+9-24)  
Java HotSpot(TM) 64-Bit Server VM (build 16.0.1+9-24, mixed mode, sharing)

Could someone help me out?

---

<div class="post-metadata">

### Author: ![albaker](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.stardog.com/albaker/32/632_2.png) [@albaker](https://community.stardog.com/u/albaker)
#### Post date: [August 2, 2021, 1:31pm UTC](https://community.stardog.com/t/problem-with-server-start-up/3171/2 "2021-08-02T13:31:57Z")

</div>

Stardog is tested and supported on Java 8 and 11. Besides VM options, Stardog also does some direct memory management and shouldn't really be used on a different version of the JVM.

Can you try 8 or 11?

---

<div class="post-metadata">

### Author: ![mereolog](https://avatars.discourse-cdn.com/v4/letter/m/ebca7d/32.png) [@mereolog](https://community.stardog.com/u/mereolog)
#### Post date: [August 4, 2021, 4:50pm UTC](https://community.stardog.com/t/problem-with-server-start-up/3171/3 "2021-08-04T16:50:18Z")

</div>

At the moment using Java 8 or 11 is not an option for me, but I am going to use a instance of Stardog on a running remote server, so thanks for the tip.

---

<div class="post-metadata">

### Author: ![system](https://canada1.discourse-cdn.com/flex030/uploads/stardog/original/2X/e/ed66b48a616f505106a4acde3c9cee7e6da9bc67.svg) [@system](https://community.stardog.com/u/system)
#### Post date: [August 18, 2021, 4:50pm UTC](https://community.stardog.com/t/problem-with-server-start-up/3171/4 "2021-08-18T16:50:35Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
