Can't run Stardog Studio-1.11.0 on Ubuntu14.04

I was running an very old version of Stardog Studio (one of the first) on Ubuntu 14.04. It worked just fine. I downloaded and installed version 1-11.0, which no longer runs. When I try to run it, I got this error which I have seen reported in other posts here
A JavaScript error occurred in the main process
Uncaught Exception:
Error: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by

and when I checked using
strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
this version (3.4.20) was missing.

So I tried to fix the problem by running
sudo apt-get upgrade libstdc++6

Now, I have GLIBCXX3.4.20

but when I run stardog-studio, I get this error message
(base) bonnie@gabbagabba:~/Stardog Studio-1.11.0$ stardog-studio &
[4] 14857
(base) bonnie@gabbagabba:~/Stardog Studio-1.11.0$ stardog-studio: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by stardog-studio)
/opt/Stardog Studio/stardog-studio: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /opt/Stardog Studio/stardog-studio)
A JavaScript error occurred in the main process
Uncaught Exception:
Error: /tmp/.org.chromium.Chromium.JTS4bo: symbol _ZTTNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:160:31)
at Object.Module._extensions..node (internal/modules/cjs/loader.js:722:18)
at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:169:18)
at Module.load (internal/modules/cjs/loader.js:602:32)
at tryModuleLoad (internal/modules/cjs/loader.js:541:12)
at Function.Module._load (internal/modules/cjs/loader.js:533:3)
at Module.require (internal/modules/cjs/loader.js:640:17)
at require (internal/modules/cjs/helpers.js:20:18)
at Object. (/opt/Stardog Studio/resources/app.asar/node_modules/nsfw/lib/src/index.js:3:16)
at Object. (/opt/Stardog Studio/resources/app.asar/node_modules/nsfw/lib/src/index.js:130:3)
Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"

I haven't seen any reports for this one.

Is there any way to get the old version of Stardog Studio? It ran just fine.
Is there any way to re-enable the webconsole?
Is there any other way to easily run and debug queries?

Thanks

It looks like a similar problem I had when running it on CentOS. I was thinking of putting together a docker container so I could run it on CentOS maybe that would help you as well.

You will need to run apt-get upgrade at this point to get all the deps match up to the libcxx that you installed.

I thought that maybe I'd give this a try https://github.com/mviereck/x11docker

It would still require root but might not if I can get it running with podman

Just a quick follow up. Getting Studio to run in a docker container was fairly straight forward although the image weighed in at 1G. I'm sure that could be reduced significantly which I will continue to look into. That's all that I need to get Studio running under CentOS so it solves my immediate problem but I'm still looking into getting it to run rootless with podman. I'm not too familiar with podman and there seem to be some things that need to be done to get it to run rootless.

ADDITION:

I managed to get it down from 1.6Gb to 958Mb. It looks like the X and Gtk stuff pulls in the world and I can't seem to find any slimmed down base images to use so that might be as good as it gets without a bunch of work. Personally I'm ok with that, studio is worth a gig :wink:

I’m going to try a multistage docker build and just pull in the library files and hopefully it will be a reasonable size

ADDITION:

possibly use elf statifier? http://statifier.sourceforge.net/ https://github.com/greenpau/statifier

ADDITION:

stratifier is old and maintained. Perhaps https://github.com/electron-userland/electron-installer-redhat

Ok, I'm done. I'll stick with the big-ol-docker container for now.