Error migrating 5.3 database to version7

I have been running Stardog 5.3.1. My databases and license key are in /var/opt/stardog. I now need to upgrade to Stardog7 because my 5.3.1 installation was mistaken wiped out. I downloaded version 7, and installed the new license in /var/opt/stardog7. Following the migration instructions, I went into my freshly installed stardog7 installation and typed

stardog-admin server migrate /var/opt/stardog /var/opt/stardog7

Unfortunately, it did not work. The first error message printed out was

log4cplus:ERROR Unable to open file: ${STARDOG_HOME}/starrocks.log

It then printed out some messages indicating it was migrating data

WARN  2019-08-23 18:41:54,307 [main] Restoring Dictionary: 98% complete in 00:00:56
WARN  2019-08-23 18:41:55,327 [main] Restoring Dictionary: 99% complete in 00:00:57
WARN  2019-08-23 18:41:55,327 [main] Restoring Dictionary: 100% complete in 00:00:57
WARN  2019-08-23 18:41:55,328 [main]

but finally died with these messages
WARN  2019-08-23 18:42:29,102 [main] com.complexible.stardog.metadata.MetadataIO:readBytes(300): Unrecognized option in the metadata: index.connection.timeout
WARN  2019-08-23 18:42:29,155 [main] Restoring database amldb
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f9f1dd9a404, pid=1308, tid=0x00007f9f1e1ab700
# JRE version: Java(TM) SE Runtime Environment (8.0_171-b11) (build 1.8.0_171-b11)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.171-b11 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  pthread_mutex_lock+0x4
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /opt/stardog-7.0.0/hs_err_pid1308.log
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

I have no idea what might have happened. Is it because I am going from version5 instead of version7? You can see from the error message that it is running Java8, so that isn't the problem. The machine is Ubuntu 14.04 and has 16GB RAM, and has not caused any problems running under version5.3.1.

thanks for any advice.

Hi Bonnie,

I seem to recall a post giving instruction for migrating to 6 then 7 which seem to indicate you can not upgrade straight to 7. Note it just an assumption on my part, here the link to the post Problems by installing Stardog

@stephen--the author of the post--can confirm whether that is correct

Hi Bonnie,

Could you either send or attach the /opt/stardog-7.0.0/hs_err_pid1308.log JVM crash log so we can take a look into what happened?

I'm also attempting to migrate an old Stardog 5 home that I had to see if I can reproduce.


Yes, of course. Here it is, and thanks for taking a look.

hs_err_pid1308.log (136 KB)


Yes, I did see that and checked the link on migrating to version 6. But the changes, at least as I read them, seem mainly to be the fact that the web console was being dropped, and changes to the API (which does worry me, but I don't think it should change
the data migration step). I didn't see anything in the notes on migrating to version 7 that said you have to go from version 6. But I did ask the question in my post below, because it is possible that is the problem. If it is, I can certainly try doing it
in steps.



Any updates here?
Is it possible that I need to increase memory using STARDOG_SERVER_JAVA_ARGS? If so, what is a good setting?
Any other ideas? Is there a way to migrate the data the databases one by one? I can't export because I completely lost my 5.3 installation and have no way to get it back. I am starting to get a little concerned because I really need my databases back.

Does the user that is running stardog have write permission to the ${STARDOG_HOME} directory?

I will check that. Also, should STARDOG_HOME be set to the new version (/var/opt/stardog7) or the old (/var/opt/stardog). The online migration instructions don't specify. I realize to run the new stardog, I need to change STARDOG_HOME, but it isn't clear what it should be for the migrate utility.

Good question. I would guess that it needs to be set to Stardog 7 since you give the migration command the path to both the old and the new database location and you want to be running 7.

When running the command: stardog-admin server migrate /var/opt/stardog /var/opt/stardog7, you actually specify BOTH homes, the value of $STARDOG_HOME isn't read. Once the migration is done, however, you would want to set it to the Stardog 7 home.

One alternative solution I will offer is that currently Stardog 7 does not support Windows, and because of that we still offer Stardog 6.2.3 for download on the website. Stardog 6 would be able to read your stardog 5 home (I would still make a backup copy to be safe). Once it starts up you would be able to stardog data export your databases to have backup RDF files. You could then even finish the migration to 7 and recreate your databases from the RDF files.

Just be careful that you're running the right stardog-admin. It might not use $STARDOG_HOME for the migration but I usually set my path with STARDOG_HOME. I'd use the full path just to make sure you're running what you think you're running.

It worked this time! I completely reinstalled everything, and ran it, and it worked. I have no idea what I did differently this time. But my data migrated and I was able to start Stardog.

New problem - upgraded Stardog-studio won't run. I posted about that in the subforum for Stardog-Studio

Thanks for all your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.