No named graphs returned with reasoning explain --print-named-graphs

Hi Community,

I have been using reasoning explanation feature a lot in my development.
However, I have found that the command stardog reasoning explain --print-named-graphs doesn't return named graphs even though there is named graphs associated.

For example, I use LUBM dataset, execute the command and get the result:

In my database, triple :FullProfessor1 :owl#headOf is in graph id, but it is never returned by this command. I have tried this in stardog 4.2.4, 4.2.2, 4.1.3, and 4.0-RC2, none of these works.
I am wondering what I should do to fix this problem?


Hi Robert,

It appears that you’re keeping the default output format of Turtle, which doesn’t support named graphs. Try adding a parameter with the --output-format option set to Trig, Nquads, etc. that support displaying named graphs

Edit: The default output format is actually TEXT, but I’m willing to bet that it’s based on Turtle, since that’s the default most places it can be.

Thank you Stephen,

I have used --output-format option, but no graph names returned...

I also checked if the named graph is still in the database, and it turns out to be there.

I also tried to use Java APi to retrieve all named graphs: Proof.getNamedGraphs() will also never return any...

Hi Robert,

Could you send/attach the dataset you’re using? I am unable to reproduce this problem with both a fake dataset I created and a LUBM dataset that I found.

If it’s too large, could you at least send an export of the triples/quads needed to make this assertion?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.