Stuck in computing statistics phase in 100% while loading freebase using bulk_load settings. Is there any reason for that?

Freebase loading in stardog is stuck in 100% in computing statistics phase from 13 hrs.
Is there any specific reason for that?
my server settings are:
export STARDOG_SERVER_JAVA_ARGS="-Xmx8g -Xms8g -XX:MaxDirectMemorySize=8g"
string.parsing=false in stardog.properties.

We are currently looking at what might be the same issue reported yesterday. If you could attach a thread dump of the server process (for example, using jstack), that would help.

Thanks,
Pavel

plz find thread dump of respective process:thread_dump.zip (7.9 KB)

Hi Pavel,
I am waiting for your reply on my thread...

Thank You

Hi Shishir,

Please see my response in How to disable statistics in stardog 7.0.1

I believe your problem is the same but, unfortunately, it may take longer to load Freebase since it's a very large dataset. The main issue is that it's very diverse in terms of the number of distinct relations and how they compose in the graph. That creates problems for statistics. You may try to load it partially, i.e. not everything but what your project needs, with data add and index.statistics.update.automatic=false, as explained in the other thread.

We will look at it more closely before the next release, the issue number is #7959, you may look it up in the release notes.

Best,
Pavel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.