Can't start in OS X on 8.1.0 -- java.lang.UnsatisfiedLinkError: no Starrocks in java.library.path

Have tried both a cask install and a zip based install and same error.

I've even explicitly set my LIB_DIR in to the lib dir of the install which contains the various starrocks libraries but still no dice.

ERROR 2022-09-09 07:02:49,370 [main] com.stardog.starrocks.StarrocksUtils:dumpLibraryInformation(115): Unable to load native library(Starrocks):

java.library.path = </Users/akimball/dev/apps/stardog-8.1.0/lib>

LD_LIBRARY_PATH = {/Users/akimball/dev/apps/stardog-8.1.0/lib}

java.lang.UnsatisfiedLinkError: no Starrocks in java.library.path: [/Users/akimball/dev/apps/stardog-8.1.0/lib]

at java.lang.ClassLoader.loadLibrary( ~[?:?]

at java.lang.Runtime.loadLibrary0( ~[?:?]

at java.lang.System.loadLibrary( ~[?:?]

at com.stardog.starrocks.StarrocksUtils.loadLibrary( [stardog-8.1.0.jar:?]

at com.complexible.stardog.Stardog.<init>( [stardog-8.1.0.jar:?]

at com.complexible.stardog.Stardog.<init>( [stardog-8.1.0.jar:?]

at com.complexible.stardog.Stardog$StardogBuilder.create( [stardog-8.1.0.jar:?]

at [stardog-cli-8.1.0.jar:?]

at [stardog-cli-8.1.0.jar:?]

at com.complexible.stardog.cli.CLIBase.execute( [stardog-cli-8.1.0.jar:?]

at com.complexible.stardog.cli.admin.CLI.main( [stardog-cli-8.1.0.jar:?]

Failed to load any starrocks library
(base) akimball@MAC lib % pwd
(base) akimball@MAC lib % ls
MSVCP140.dll			VCRUNTIME140.dll		libStarrocks.dylib

Is the OSX system where you're attempting to run Stardog using a non-Intel chipset (M1 or M2)? If so, you must first install Rosetta. See macOS Installation | Stardog Documentation Latest for more details.

Yep, I've installed Rosetta. If I run 'pgrep oahd" - I get the active process for oah. Other apps requiring Rosetta are functioning too. Any other ideas?

Thanks for your help!

We have run Stardog successfully on Apple chipsets with Rosetta, so I am not sure what else to suggest with regard to diagnosing your problem when attempting to run locally.

A different approach would be to sign up for a Stardog Cloud account (on, click the "Get a Stardog Cloud Instance" button, and then create a free instance.

Thanks, Paul. I see a colleague of mine also had the same issue (Rebecca Jackson #3953) - we both tried the install and failed in the same way AND posted to the community site without any knowledge of the other! So, something is amiss but it could be a common config on our shop supplied laptops. I've installed 8.0 without incident on this same box before it had to be re-imaged.

On my M1 Mac, I can run Stardog via Rosetta if I'm running an Intel JVM (also through Rosetta). This was the only way to reliably ensure that the java process found the native code properly

Thanks, Stephen. You inspired me to try some other options.

In the end, I got it running by downgrading to the following runtime:

OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_292-b10)

Amazingly, it fired right up. No idea why the AdoptOpenJDK 11 failed after multiple clean installs, but it did.