Error creating Virtual Graph through MYSQL

Hi,

I am getting the following error while trying to add a virtual graph through MYSQL database. I have already installed the connector/J and placed the jar file in the STARDOG/Server/dbms.

The error is as follows:

" Failed to create virtual graph "name": 000012
java.sql.SQLEception: Access denied for user "@"localhost" (using password: NO) (internal server error) "

Can you please provide the next steps to go forward?

Regards

It sounds like you have a problem in the property jdbc.username or jdbc.url. Can you share the contents of your properties file with the password removed?

I don't have a JDBC username / password. Below is the content:

JDBC Connection URL: jdbc:mysql://localhost:3306/database_name
JDBC Username: [blank] - haven't really setup anything so far
JDBC Password: [blank] - haven't really setup anything so far
JDBC Driver Class - com.mysql.jdbc.Driver

As the error message says, blank username is not authorized to connect to the database. Please check your database permissions.

Hi Jess,

I was able to solve for this issue. Database properties are now being used as an input. I am still getting an error:

"could not initialize class sun.security.ssl.SSLSessionIMPL (internal server error)".

Can you please help with the error above? Are there some settings on the MYSQL side that needs to be updated?

Regards,
Touseef

Hi Touseef,

In order to analyze the root cause of this error, can you please provide the following:

  • Version of Java running Stardog
  • Version of MySQL Connector/J JDBC driver
  • Complete stardog.log file from the Stardog server
  • Version of Java running Stardog - Version 1.8.0_261-b12
  • Version of MySQL Connector/J JDBC driver - MYSQL Connector Java 8.0.21
  • Complete stardog.log file from the Stardog server - Can you tell me where to get this from? I do not see an updated file in the logs folder.

Either you have set the STARDOG_HOME environment variable, or it would by default be set to the directory from which you launched Stardog via the stardog-admin server start command.

You can also try adding ?useSSL=false to your jdbc.url in the properties files.

Okay thanks!

So I added ?useSSL=false to my JDBC URL and I was able to create the connection.

Currently, I am using 'auto generated mapping' and 'All Databases' in the Stardog database option. I was able to create the virtual graph but with the following error:

" Failed to request mappings to virtual graph "McD": 000012 Could not initialize class com.complexity.stardog.protocols.http.server.protocolUtils (Internal Server Error) "

Questions:

  • Can you help me with the error above?
  • Do I need to assign the virtual graph to a database?
  • Also, in what format does a data mapping file needs to be in? I have a .OWL file with me that I created in Protege.

Did adding 'useSSL=falseto yourjdbc.url` in the properties file not work?

You can or you can not assign it to a database in which case it's universally accessible from any database

The date mapping files can be written in three fromats

SMS - The first iteration of a custom Stardog mapping format. May be deprecated in the future
SMS2 - The newer Stardog mapping format.
R2RML - W3C standard mapping format

The owl file that you created in protege can just be loaded directly into your database.