Problem adding MySQL virtual graph

I am having trouble testing the virtual graph feature against a sample MySQL employees database. I’ve created the file similar to what is shown in the documentation:


Then, I use the following command:

stardog-admin virtual add /Users/me/stardog-5.2.3/bin/

I get the response:

Not Found!

I’ve also tried with port :3306 after localhost in the file, but I get the same result, Not Found!

I have not included a mapping file since the documentations says, “If there are no mappings provided to the add commands then the R2RML direct mapping is used.” So, I’ve assumed you can omit mapping file to end up with R2RML direct.

Can anybody help me understand what I might be doing wrong?

Hi Cody,

The virtual graphs feature is not part of Stardog community. Are you using Stardog community?


Yep. I’m currently using community. I just actually noticed that in another note:

“virtual graphs are an enterprise feature so you’ll need either a developer, enterprise or 30-day trial license.”


Just to confirm, I replaced with 30 enterprise trial license key and sure enough, now I got the response:

Successfully added virtual graph emp

Thanks, again for quick response.

Glad it’s working! Let us know if you have any other questions/comments.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.