PATHS query in webconsole returns error


(Bonnie MacKellar) #1

Hi,

I am running Stardog5.3, and using the query window in the websconsole through my browser to test queries. Most are working fine, but I tried the PATHS query, and keep getting a parse error. I know this is new. Is it not possible to run these via the webconsole?

This is my query
PATHS START ?x = ct:NCT00352534 END ?y via ct:hasIntervention

I also tried
PATHS START ?x = ct:NCT00352534 END ?y via ?p

I get this error in both cases:
Parse error on line 5:
…inicaltrialproj/>PATHS START ?x = ct:
--------------------^
Expecting ‘BASE’, ‘PREFIX’, ‘SELECT’, ‘CONSTRUCT’, ‘DESCRIBE’, ‘ASK’, ‘LOAD’, ‘CREATE’, ‘INSERTDATA’, ‘DELETEDATA’, ‘DELETEWHERE’, ‘DELETE’, ‘INSERT’, ‘WITH’, ‘CLEAR’, ‘DROP’, ‘ADD’, ‘MOVE’, ‘COPY’, got ‘INVALID’

Am I doing something wrong in the syntax? I tried to follow the examples in the manual.


(Bonnie MacKellar) #2

Hi,

I just tested it. The query works perfectly on the command line. But in the webconsole, it returns the parse error shown above.
I am running the webconsole via browser from another machine because entering queries on the command line on the remote server is a bit of a pain. Would that make a difference somehow?


(Pavel Klinov) #3

Hi Bonnie,

You’re correct, PATHS feature isn’t supported in Webconsole. That legacy UI is basically deprecated and is being replaced by the new Stardog Studio UI: https://www.stardog.com/studio/. It already supports paths.

In addition you can run queries against a remote server from your local shell.

Best,
Pavel


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.