Unable to load a validated url

Hi,
the following update statement gives a strange error in stardog 4.2.1 (IRI included an unencoded space: ‘32’ [line 1]):

LOAD https://www.dati.lombardia.it/resource/xgjs-xm83.rdf?$limit=10

The same url validated with w3c validator. Could be a bug?

Hi, SPARQL requires URIs to be surrounded by < >. Try that and you should be OK.

Of course, I know. They have been removed by html. It does not work even
when surrounded by <>

I was thinking that the URI encoding issue could possibly be from the file
you’re trying to load and not from the URI you’re trying to load it from
but it appears to be valid. It might be getting confused about what
serialization format that it’s in. Can you check stardog.log and send
along any errors in there?

My apologies, that just seemed like the obvious problem. After looking into it a little more, I have found a bug with our RDF parser. Because of the query parameter it is unable to tell that the format is RDF/XML and is trying to process the document as Turtle. I have opened up an issue and a fix for it should be in the next 5.0 release.

In the meantime, you could remove the limit of 10, or you could download the file manually and add it via stardog data add and that will work.