User does not have permissions to update the named graph DEFAULT

stardog data add command failing with error "User does not have permissions to update the named graph DEFAULT" . user already have access of all the named graph.

I tried changing named graph but it didn't helped.

Hi Manish,

Can you share the output of stardog-admin user permission (docs for this command) for the user having this issue?


Hi @StevePlace, What is the URI for default named graph.

We have assign following roles to the user - role grant -n $ROLE_NAME -a all -o named-graph:*.

Hi Manish,

As per the documentation, wildcards cannot be used for named graphs. If you need named graph security enabled, you need to essentially whitelist the specific graphs to which people have access. Stardog provides the special IRI tag:stardog:api:context:default to refer to the default graph, even though technically it has no IRI.

Hi @stephen ,

It worked

stardog-admin user grant -a write -o named-graph:my-database1\tag:stardog:api:context:default [user]