"Virtual add ttl" problem -- "unknown database ..."

Dear all,

I was following "Using Virtual Graphs" tutorial to create a graph database, everything went well until when I tried to add ttl file to the database. Here is the detail,

First, I started the server successfully by running
$ stardog-admin server start --web-console

Then, I successfully created a database named "music" by running
$ stardog-admin db create -n music

However, after that, when I add a graph by running
$ stardog-admin
virtual add music.properties music_mappings.ttl
, it return the following error message:
Unknown database "music"
, although at the previous step the empty database "music" was successfully created and clearly shown at localhost:5820.

I also tried another way to add graph by running
$ stardog-admin db create -n music music_mappings.ttl

It returned the following error message:
Bulk loading data to new database music.
Errors were encountered during loading:
/home/ying/music_mappings.ttl: Expected ':', found '}' [L4]
Loaded 0 triples to music from 1 file(s) in 00:00:00.508 @ 0.0K triples/sec.
Successfully created database 'music'.

The line4 of music_mappings.ttl is
:Album{id} a :Album ;
So it is not possible that the "}" should be replaced with ":".

I have tried all the way that I can possibly think of but couldn't get the ttl file added to the empty database. Did I miss anything? Any suggestion are highly appreciated!


It sounds as if the Unknown database "music" may be referring to your RDBMS. The "RDBMS SETUP" heading of the tutorial expects you to load the .sql files into the relational DB of your choice, so it is also expecting a "music" database there.

Stephen, problem has been solved by following your suggestion. Many thanks! Ying

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.