After CTRL+C "stardog-admin.bat server start" do nothing


(Quico Llinares Llorens) #1

Hi, I come from here.
Finally I achieved to run the server, then I stopped it doing “CTRL+C”. After that, the server was not stopped, since I could see the server at the Stardog port, so I decided to kill the process, after that the server was stopped, but then I try to do “stardog-admin.bat server start” and it is like is doing nothing.

Here I leave you a picture of it.
Captura

Thanks for your help.


(stephen) #2

Is anything showing up in %STARDOG_HOME%\stardog.log that might explain the behavior? Are other stardog.bat / stardog-admin.bat processes able to connect to anything?


(Quico Llinares Llorens) #3

I have this in the logs:

WARN 2018-08-04 19:08:04,931 [main] com.complexible.common.memory.PlatformDependent:(144): sun.misc.VM is not available
WARN 2018-08-04 19:08:49,513 [main] com.complexible.common.memory.PlatformDependent:(144): sun.misc.VM is not available
WARN 2018-08-04 19:10:50,364 [main] com.complexible.common.memory.PlatformDependent:(144): sun.misc.VM is not available
WARN 2018-08-05 12:06:27,763 [main] com.complexible.common.memory.PlatformDependent:(144): sun.misc.VM is not available
INFO 2018-08-06 17:18:30,717 [main] com.complexible.stardog.StardogKernel:start(2333): Initializing Stardog
INFO 2018-08-06 17:18:33,914 [main] com.complexible.stardog.cli.impl.ServerStart:call(249): Memory options
INFO 2018-08-06 17:18:33,952 [main] com.complexible.stardog.cli.impl.ServerStart:call(250): Memory mode: DEFAULT
INFO 2018-08-06 17:18:33,953 [main] com.complexible.stardog.cli.impl.ServerStart:call(251): Min Heap Size: 2,0G
INFO 2018-08-06 17:18:33,953 [main] com.complexible.stardog.cli.impl.ServerStart:call(252): Max Heap Size: 1,9G
INFO 2018-08-06 17:18:33,954 [main] com.complexible.stardog.cli.impl.ServerStart:call(253): Max Direct Mem: 1,0G
INFO 2018-08-06 17:18:33,954 [main] com.complexible.stardog.cli.impl.ServerStart:call(254): Max Mapped Mem: 115M
INFO 2018-08-06 17:18:33,955 [main] com.complexible.stardog.cli.impl.ServerStart:call(255): System Memory: 16G

I think g.e. stardog.bat do something, but I have never used it (I am new with Stardog) and don’t know what to do.


(Jess Balint) #4

Can you share the output of running java -version?

Jess


(Quico Llinares Llorens) #5

C:\Users\quico\Desktop\Stardog\stardog-5.3.3\bin>java -version
java version “1.8.0_181”
Java™ SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot™ 64-Bit Server VM (build 25.181-b13, mixed mode)


(zachary.whitley) #6

I’m a little confused at his description of doing a CTRL-C to stop the server. Does the windows startup script not daemonize it?

Do you by any chance have a system.lock file in $STARDOG_HOME. It should give a warning if you try and start it and it’s there but it’s something you can try looking for. If it’s there try deleting it and seeing if it starts.


(Quico Llinares Llorens) #7

I have deleted the system.lock, and I am getting the same results.


(zachary.whitley) #8

Interesting that it was actually there. Can you check your Task Manager and make sure there isn’t a process already running Stardog?


(Quico Llinares Llorens) #9

I have checked on processes and services and there is no Stardog.


(stephen) #10

Can you look at JAVA_HOME and ensure that it’s set to your Java 8 installation and not a 9/10 one?


(Quico Llinares Llorens) #11

I hadn’t the %JAVA_HOME% variable, but I set now, anyway still not working.
Captura


(zachary.whitley) #12

You can try rebooting the machine, set JAVA_HOME, set STARDOG_HOME, and see if it comes up.


(Quico Llinares Llorens) #13

I have rebooted the machine, and same results.Captura


(zachary.whitley) #14

As @stephen had mentioned %STARDOG_HOME% doesn’t have to point to your installation directory and can point to a separate data directory but in that case you would need to set %STARDOG% to point to your installation directory.


(Quico Llinares Llorens) #15

I guess you mean the following. Still not working.Captura


(zachary.whitley) #16

Ok, one last thing and I think I’m out of ideas. Is your license in %STARDOG_HOME% ?

It should be returning errors if it isn’t but other than that I’ve got nothing.


(Quico Llinares Llorens) #17

Finally I have done a virtual machine with Ubuntu, and it is working ok there.

Thanks for your help.