Cannot upload files (using BITES)


I’m trying to upload a file using CLI:
stardog doc put test file.pdf
but it responds with “No value present” message.
With verbose mode on (-v), the following backtrace is output:

No value present
The detailed stack trace for the error is:

com.complexible.stardog.cli.CliException: No value present
at com.complexible.stardog.cli.CLIBase.execute(
at com.complexible.stardog.cli.CLI.main(
Caused by: com.complexible.stardog.StardogException: No value present
at com.complexible.stardog.protocols.http.client.BaseHttpClient.checkResponseCode(
at com.complexible.stardog.protocols.http.client.BaseHttpClient.execute(
at com.complexible.stardog.protocols.http.client.HttpClientImpl.execute(
at$$Lambda$17/675833472.apply(Unknown Source)
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(

When I try and use the web UI (“Document Store” tab > “Upload file”), I’m getting HTTP 405 error (as reported in the tooltip for the non-uploaded file icon). I tried different files, in different formats (jpg, pdf, txt, etc.), but nothing works.

Am I missing something?

P.S.: I use stardog-4.2.3 on MacOSX 10.12.3, starting the server with “stardog-admin” command, nothing fancy there.

Hi Slava,

Do you see any error messages in the server log (stardog.log) when you run this command?


Hi Jess,

No, stardog.log is not updated at all when this error pops up.

Btw, if it’s of any help, I’m running the stardog server at port 5830 (which is not the default 5820), so the full command invocation looks like:
bin/stardog doc put http://localhost:5830/test file.pdf

I’ve been playing with other Stardog features, and can confirm the rest of them works fine with this setup.

Are you able to run doc count on that database?

No, I’m getting the same “No value present” error.
I tried creating other DBs, enabling/disabling different features (e.g. full-text search), but no cigar.
Also, checked Java version, just in case - it’s 1.8.0_51. I guess, that’s fine too.

Hi Slava,

The BITES feature is not enabled when you run Stardog with a community license. I will update the documentation and error handling to reflect this.


Oh, I see.
Thanks for the help anyway! :slight_smile:


I apologize that we wasted yr time in this way. But Stardog Enterprise 30-day trial is free from the website and you can just drop in that license key and restart. Then you can evaluate BITES.

Hi Kendall!

No apologies necessary. I appreciate your prompt support and dedication to
Stardog, even when it’s about a non-paid version.

I will try the enterprise license key, as you suggest.

Thank you!

Here’s an update on the issue: after I’ve used the developer/enterprise 30-day trial license, the CLI upload works fine, but the Web UI still produces “Server responded with 405 code” error message (“Document Store > Upload a File” page). Not a big deal now that I can use CLI, but I guess that still qualifies as a bug :slight_smile:

Moreover, “Document Store” page does not list any documents at all, although stardog doc count says that there’s more than 0 documents there.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.