Cli slow response time

Stardog 5 RC1 on macOS 10.12.5 (16F73)

I have a screenrecording, but not able to upload.
Response time indicated is milliseconds while it takes 8 seconds to show up on the cl.

I noticed something similar and was going to post something but checked on 4.2.4 and it has a similar overhead. I guess I had gotten used to it. I’ve occasionally tried using using drip to avoid the jvm starup time with little success.

Is there any output in your stardog.log that might show something to be happening around the query execution? Do you have any $STARDOG_JAVA_ARGS set? Does your machine have some kind of firewall slowing down HTTP traffic?

Hi Stephen,

a) nothing in the output of stardog.log
b) initially with default settings, changed afterwards to
STARDOG_JAVA_ARGS="-Xmx8g -Xms8g -XX:MaxDirectMemorySize=4g" but with no difference
c) not that I’m aware of.

I’ll try on another machine also.

Yeah, I would try on another machine, as I can’t seem to reproduce this. It looks like you’re just talking to localhost? That would still make an HTTP call…perhaps wireshark could tell you something?

I’ll take a look at the machine I’m seeing it on as well. I’m trying it on a different machine right now and it’s taking around 1.5s for a query that returns in 0.05 seconds which is what recall as being normal but I was seeing times between 8-10 seconds on trivial queries at home. Whatever it is, it’s not specific to 5.0.

Paul, what JVM are you using?

java -version
java version "1.8.0_121"
Java™ SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot™ 64-Bit Server VM (build 25.121-b13, mixed mode)

Tested it on another Mac and there the queries return in 1.2 seconds.

On the slow Mac, the query loses 6 seconds with the MDNS protocol (1 second on the other machine). Something Bonjour related?

If you filter your wireshark output to just HTTP (I like to use (http.request || http.response)), are the extra 6 seconds coming before the request, in between request and response, or after the response?

before the request; the http request at position 17.

So you initiate the CLI command and the HTTP request to the server doesn’t get sent for 6 seconds?

Yes, that’s my diagnosis.

I’m seeing this on a Linux machine. Is there a possibility that this could be an IPv6 issue? You might want to try disabling ipv6 and seeing if that helps.

Doesn’t seem to give a difference.
The IPv6 settings of the fast Mac are the same.

The only difference I’m aware of is that the fast one is on Ethernet and the slow one on Wi-Fi.

Here are a couple of threads that I'm looking into


1 Like

Yes, a similar issue exists on the Mac. I’ll investigate further. Thanks for all the input and feedback.

The real solution was a reboot of the Mac.

So just rebooting fixed your problem or are you saying that you made some configuration changes to your system that required a reboot?

Yes, just rebooting.
No config changes made.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.