Stardog 5 beta issue

This may be a bug report a newbe problem. Stardog 5 current beta on a Ubuntu VM under windows 10.
On server start I got this error:


On the host machine I can access the admin console but not the list of databases or query, when directly entering the database URL, could not browse it. I did not have this problem under Stardog 4.

The VirtualGraphHttpService error is a known issue that is very close to being fixed. It is displayed only because you’re using a community license. It shouldn’t affect anything, however.

Are you able to list or query the databases via the CLI? If you’re trying the web console, do you see any errors being output to the javascript console in the browser?

Not a newbie problem but indeed a bug but it’s always nice to have another set of eyes bug huntin’. Welcome to the Stardog community. See this previous report Virtual graph incompatible constructor

I missed your last sentence. Can you elaborate on [quote=“CoryCasanave, post:1, topic:320”]
On the host machine I can access the admin console
[/quote]

Do you get a response when you execute the following?

stardog-admin server status

On a client machine the web interface hangs on http://192.168.1.88:5820/FIBO-Master#!/query or browse. On the stardog host query and browse works.
On the host and client machines server status returns as normal.
Note the stardog host (Ubuntu) is a VM running under the “client” (Windows 10)

I’m still not completely clear about the exact problem you’re having. It would be helpful if you could include what exact commands you’re executing, where you’re executing them from, what the response is, and what the expected behavior is if it is not what was returned.

From what you’ve said and if I understand it correctly I would guess that you’re firewall is dropping packets to port 5820 from anything other than localhost which is why it appears to hang when you connect from a client.

I bring up Stardog 4 on a Ubuntu VM. It has a “FIBO-Master” DB. I can access that DB wit this url: http://192.168.1.88:5820/FIBO-Master#!/query using internet explorer 11. I can query the DB,

I bring up Stardog 5 on the same VM (after stopping SD4). It has a separate DB with the same name. I use the same URL from the same browser and it hangs. There is no message. The expected behavior is the query screen as is shown by SD 4.

On both 4 & 5 I can access the admin console.

I will let you know if I discover anything else.

That rules out a firewall issue. Can you successfully query Stardog 4 and 5 from the client machine using the CLI?

Hi,

Thanks for reporting this. It appears to be an issue specific to Internet Explorer (and MS Edge). We will fix it in an upcoming release. In the meantime, you can either use a different browser or any of the other APIs (CLI, HTTP, Java, etc.) to access your database(s).

Hi,

when I am trying to query the database through my node app. it is throwing following error.

:ERR_CONNECTION_TIMED_OUT

and when I go to GUI and click query option it shows the following data.

@prefix : . @prefix owl: . @prefix pii: . @prefix rdf: . @prefix rdfs: . @prefix stardog: . @prefix survey: . @prefix xsd: . a owl:Ontology . survey:assessment a owl:ObjectProperty ; rdfs:range survey:AssessmentRule ; rdfs:domain survey:QuestionGroup . survey:AssessmentRule a owl:Class . survey:QuestionGroup a owl:Class

Stardog is setup on Azzure server and application is running in local there.

could anyone provide some valuable suggestions.

Thanks in advance,
Yashpal Singh

Hi Yashpal,

This thread is about the problem you are experiencing with the GUI and can be worked around by using a browser other than IE/Edge.

As for the connection timeout, please open a separate thread with the details of how you are receiving it, including the query you are sending, how you are sending it, etc.

I have confirmed it is a browser issue. The timeout was in the browser so it is the same problem.