Docker issue: STARDOG_HOME '/var/opt/stardog/' is not writeable by the current user

I am trying to follow instruction in Use Docker | Stardog Documentation 7.6.4 with Docker on Windows. I have placed my license file "stardog-license-key.bin" in the "~/stardog-home" directory.

When I run " $ docker run -it -v ~/stardog-home/:/var/opt/stardog -p 5820:5820 stardog/stardog", I get the following error message "STARDOG_HOME '/var/opt/stardog/' is not writeable by the current user".

I found this support topic Can't start with Docker - STARDOG_HOME not writeable by the current user. However, when I run "docker run -it -v ~/stardog-home/:/var/opt/stardog -p 5820:5820 stardog/stardog", I then get this error message "A valid Stardog license was not found in /var/opt/stardog. Please copy your license file to this location or visit https://stardog.com to acquire a new license."

Hi Kris,

If you are Windows, the path on the host machine provided to the first part of -v option likely should have backslashes (\) in it. Can you please try providing the absolute path of the directory containing the license file on your host machine as the first part (before the :/var/opt/stardog) of the -v option in your docker run command?

Cheers,
Noah

Thanks @noahgorstein! I tried changing to backslashes like so "docker run -it -v .\stardog-home\:/var/opt/stardog -p 5820:5820 stardog/stardog", but now I get the following error message "docker: Error response from daemon: .\stardog-home%!(EXTRA string=is not a valid Windows path)."

Actually, I didn't read your message carefully enough. When I supplied the absolute path to the stardog-directory on my machine, it worked. So for windows it looks like something like the following would work:
"docker run -it -p 5820:5820 -v C:\Users<username>\stardog-home:/var/opt/stardog stardog/stardog"

Thanks for the help! Excited to get rolling with Stardog!!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.