No object found when creating virtual graph

Hi,
i am quite new to Stardog. I tried to create my very first virtual graph on top of Oracle DB. However it looks like connections is successful, but query within mapping file cannot be executed. I tried to access different object on DB, with the same result. "Object not found". Same problem occurs for Stardog and R2RML formats.

My mapping file looks like this:

material.ttl (198 Bytes)

Hi Bartek!

Virtual graphs can only be created in the enterprise or trial version of Stardog. Are you using Stardog community?

Hi @jess, currently i am using trial version. btw. DB objects are of course accessible via thin JDBC client

Can you check the contents of the stardog.log on the server and see if there is a detailed trace related to this error message?

Thank you for prompt reply Jess. Please find attached logs from server standard output (it seem my stardog.log was not created) and complete error message from commandserver.log (1.8 KB) virtual.log (251 Bytes)

Is V_MATL_DEPENDENCIES in the schema you are connecting with? If not, you will need to set sql.schemas as documented at https://www.stardog.com/docs/#_available_properties.

Thank you, added sql.schemas and schema name in R2RML and that solved my problem. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.