OWL/XML file format not supported in 5.0-RC1?

Hello,

I am trying to manually import an owl/xml file generated by Protege into Stardog. I am having a

Invalid file type. Please ensure that the contents of the file are valid for the chosen format.

Is owl/xml not supported anymore? or I missed something?

regards,
Charbull

Can you show the entire command you submitting?

No, OWL/XML is not supported. It’s not an RDF format. You should save your ontology in one of the RDF formats and then load into Stardog.

Cheers,
Pavel

Ok thank you,

I noticed as well the following:

My code generates an nquad format through dotNetRDF. It seems valid when I validated in EasyRDF: http://www.easyrdf.org/converter.

When I insert it manually in Stardog through the Web UI, I can browse through the WebUI. However, a simple query such as
Select ?a ?b ?c
{
?a ?b ?c
}
Don't return any result.

When I take the same file and convert it to rdf/xml and then I insert the file manually through the WebU. I can browse it correctly and when I query Select ?a ?b ?c
{
?a ?b ?c
}
I have the expected results.
output.nq (18.8 KB)

any hint? the NQuad format seems to be valid.

By default the query.all.graphs is set to false. I’m assuming that your nquads puts everything into named graphs and nothing into the default graph. rdf/xml doesn’t support named graphs so I’d also assume that it’s simply adding everything into the default graph.

The query you’re running only selects from the default graph so when you load the nquads you don’t see anything because there’s nothing in the default graph, it’s all in named graphs but when you load the rdf/xml everything goes into the default graph and you get results.

You should see your data with nquads if you run the following query

select * { graph ?g { ?s ?p ?o}}

or you can change query.all.graphs to true and you will see everything with your previous query.

1 Like

Thank you Zachary ! very true !

@zachary.whitley what is the recommended format?
I am noticing a slow performance for the queries with the query.all.graphs set to on with the nquads.

Seems the rdf/xml and query.all.graphs set to off a better option for the performance?

Can you share your queries, query plans and possibly the data? The query.all.graphs may have an impact on the performance depending on your data and the queries but that should be expected as you are querying two different datasets. If you had 1 billion triples in named graphs but zero in the default graph a query against the default graph would go from querying nothing to querying a very large number of triples.

Ok, I understand,

The query is slow just the first time after that all is good. I have only 40 triples.

thank you for the explanation.

Charbel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.