Trig and Quad formats import question/error

I am trying out trig and Nquad formats and was wondering what is going wrong.

When I insert them in Stardog (community 5.0 beta) I can see only the Class Person in the Web Browser.

And I can’t see my instance “Tim”

Any hints? I am pretty new to these 2 formats
Thank you

<> <> <> <> .
<> <> <> <> .
<> <> "Tim"^^<> <> .
<> <> "Berners-Lee"^^<> <> .


@prefix rdf: <>.
@prefix rdfs: <>.
@prefix xsd: <>.

<> {
    # Written using High Speed Mode
    <> <> <>.


<> {
    <> a <>;
                                              <> "Berners-Lee"^^xsd:string;
                                              <> "Tim"^^xsd:string.

Can you elaborate on “can’t see”? I’m guessing you mean that it’s not listed in the Stardog webconsole schema browser under Classes > Thing/Person/

Can you try to force reload in your browser? (Firefox Linux: F5, winodws: ctl-F5…)

It’s a beta release so you might not be missing anything and there might be a bug in the webconsole. I can’t try reproducing it right now because I don’t have access to a 5.0-beta install but the data should be in there you should be able to query for it.

You can also try the “Entities” option under the query panel “Explore” drop down.

Hey @zachary.whitley,

I tried reload multiple times and incognito session.
In the webconsole, there is only: Thing/Person. When I click on Person, the instances (individuals) are not listed, a

I also tried SPARQL:

Select * {
?a a foaf:Person.

I tried it in 5.0-beta and 4.2.3.


I finally looked at your data a little closer. (It wasn’t apparent because you had to scroll left to right to see it). I don’t know how you produced your data but the n-quads file looks like it’s out of order . it should be graph, subject, predicate, object but it looks like you’ve got it in graph, predicate, object, subject

I loaded your n-quads data into Stardog 4.2.1 and I can reproduce the behavior that you’re seeing. It seems to be something specific to foaf. If you change the prefix from say to something different like it appears to work.

…works in the sense that you can browse as expected.

It looks like if you register the foaf namespace with the database it works.

Go under “Databases”, select your database, take the database offline by clicking the green “on” button to toggle it to “off”, click “edit”, click “add namespace”, enter "foaf=, click “save”, then click “off” to toggle the db back online.

I changed the Foaf namespace, it was just a hello world example using the ORM - RomanticWeb:

Thank you, it works now!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.