Pystardog - how to specify verify=False

Running into certificate trust issues.

SSLError: HTTPSConnectionPool ... [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1123)')))

This SO post Solve the dreadful certificate issues in Python requests module | by Supratim Samanta | Level Up Coding has a fix like :

requests.get('', verify=False)

But how do I do that with pystardog?


Hi Radu,

There's no way in pystardog to pass in the flag to disable SSL certificate verification. That said, there's nothing stopping you from instead using the requests library directly with the Stardog REST API and passing it in yourself: API Reference | ReDoc


Thank you - HTTP API it is there indeed. But it would be nice to see this available as well in pystardog.

  • Can you please add this important dev functinality?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.