Issue with SSL Certificate

Hi guys,

When I run

$ stardog-admin.bat --server https://test.local:443 stored add --database test --overwrite -u test -p MyPassword test.rq

I get

PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

After reading https://www.stardog.com/docs/#_configuring_stardog_client_to_use_ssl, i figured out that I need to register my certificate with keytool. What I have not figure it out is how to get it. I tried

openssl s_client -connect test.local:443

and getting it from chrome, but without success. Any other recommendation?

thanks

Have not resolve our problem, but move to a solution using Stardog javascript library since we wanted to extend the functionality.

However to make it work I currently had to put this.

process.env.NODE_TLS_REJECT_UNAUTHORIZED = "0"

to temporarily resolve this

'request to https://stardog-dev.hub.cloud.res.bngf.local/admin/queries/stored failed, reason: unable to verify the first certificate',

which is obvious not something we can keep. Anyone got this work. From all research this should fix the issue,

require('https').globalAgent.options.ca = require('ssl-root-cas/latest').create();

but it did not.

Does anyone have a how to to make it work with stardog.

Thanks
-Serge

It seems like you have something wrong with your trust store or you’re running your own CA and haven’t included your certificate chain. It’s most likely a problem configuring java to use TLS rather than anything specific to Stardog. There are a lot of resources but here is one random one I came across that seems decently written.