Stardog Explorer connection fails to call /admin/token endpoint

I'm trying to connect Stardog Explorer at http://explorer.stardog.com to my database over http (not https) and the following error pops up:

image

When I check the console, I see that a call is being made to http://myserver.com:5820/admin/token which fails. If I access this endpoint directly the json response is

{
"message": "API Keys are not configured",
"code": "000012"
}

I don't see the /admin/token endpoint in the API docs at API Reference | ReDoc

Any thoughts on what's going on here?

If it helps, this was working several weeks back with this same server setup running server version 7.6.3

Note: I upgraded to 7.7.2 I am still seeing the same issue.

thanks @tim and @jason for taking a look at this with me. here is the cors config that we tried out to no avail

cors.allowed.origins = * #http://explorer.stardog.com, http://stardog.studio

We also ran into an issue setting the hostname that looks like a bug in the CLI where the --server parameter isn't registered

$ /opt/stardog/bin/stardog-admin server start --server http://stardog.dev.mazetx.com:5820
Invalid or missing options:
Found unexpected parameters: [--server, http://stardog.dev.mazetx.com:5820]
Type 'help server start' for usage information

Hi Nolan,

Thanks for the follow-up. Just to quickly confirm, do you have the same experience in an Incognito Chrome window? I just want to make sure no browser extensions are interfering with HTTP requests.

Thanks,
Jason

Yup same behavior in Ingcognito mode

Another note here is that I am able to login via Firefox with no issues, so I have a work around. Seems to be a Chrome issue related to my work laptop. Will post an update if I find a fix for that...

I am having the same issues with Studio. @nicholsn thanks for the note about Firefox. I tested it there and it does seem to work.

I am wondering if there is an identified fix / timeline for this?