After Mac OS installation, Studio has no response with http://localhost:5820

Hi, this is my first try to install Stardog in Mac OS. The server installation sounds complete, but Studio has no response with http://localhost:5820.

Besides, there is no button of Express endpoint to choose in Studio "Create New Connection" dialog. Do not know how to reach Stardog Express.


Hi Crystal,

Can you please share what browser you are using to access If you open up your browser's console, do you happen to see any error messages there?

Additionally, just to confirm the Stardog server is up and running, can you please try executing the following Stardog CLI command:

stardog-admin server status

With respect to your question about Stardog Express, if you go the connection dialog again and select "My Connections", do you see a saved connection anonymous@

If for whatever reason you do not see that saved connection, you can access Stardog Express with the following information:

  • username: anonymous
  • password: anonymous
  • endpoint:

I use Chrome browser. It shows some error massage on the browser console.

Server status:

Stardog Express works with the endpoint information you provided. Thanks. But while opening the Studio first time, there is no pre-saved "anonymous@"

The local Stardog Server is not workable still.
I have the license file in /var/stardog/

Hi Crystal, can you double check you are accessing Stardog Studio at and not The error you are seeing in your browser is consistent with using and trying to connect to a server that is not enabled to accept SSL connections.

Hi Noahgorstein,

I do access Stardog Studio at

Stardog Express works fine, but local one can not.



Are you able to view the network requests that occur when you click the "Connect" button? They should be visible in the "Network" tab of your browser's developer tools. You should see two requests to http://localhost:5820/admin/users/valid, one with the OPTIONS request method and one with the GET request method. Could you please share the Request Headers and the Response Headers for each of those requests? (You may want to remove the "authorization" header from the Request Headers, since it contains your password information.)

Also, can you confirm that you are attempting to connect directly to a Stardog server from your browser? There are no proxies, etc., in between?

Finally, can you please also try the same steps from a Chrome Incognito window, so that we can be sure that no browser extensions are interfering here?


Hi Jason,

I am not skillful with browser's developer tools. I can not find the information you advise in "Network" tab. However, I can capture what I got for your judge.

There is some error message i "Console" tab.

While I open the "localhost:5820/admin/token:1"
I shows:

Is it the problem of license file?

I all tried with Chrome Incognito.

I also tried to connect to local Stardog Server with Chrome Incognito. A pop-up windows asks me to key in user name and password. I try with
user name: admin
password: admin

then http error 404 shows.


Hi Jason,

Attachment are the information of "Network" tab. I can not find any requests to "http://localhost:5820/admin/users/valid", while I tried to connect to the local Stardog server at "http://localhost:5820"

Hi Crystal,

One reason you don't see all of the requests (including the requests to admin/users/valid) is that you have a filter applied in your Network tab. If you look at your last image, you can see at the bottom left that it is showing only "4 / 9 requests," meaning that 5 requests are hidden by a filter. If you look near the top of your console, slightly below the Network tab, you will also see that "Other" is selected; please select "All" instead (which is to the left of "Other") so that all network requests are visible. At that point, you should then be able to share the request information I asked about.

Aside from that, the last image you provided indicates that the request to http://localhost:5820/admin/token is never completing (it says "Provisional headers are shown", and shows only the request itself, but no response). This -- combined with your "failed to fetch" error message -- suggests either that your Stardog server is no longer running, or that it is not listening on the appropriate port, or that it is in some other way not communicating with your browser at all. Though it may sound silly, please double-check that your Stardog server is running and accessible and try again.

If the problem persists, there are a few additional things that may help here:

  1. What is the output of the following command in your terminal?
cat /var/stardog/
  1. What is the output of the following command in your terminal?
curl 'http://localhost:5820/admin/status' -I -X GET \
  -H 'Referer:' \
  -H 'Origin:'
  1. What is the output of the following command in your terminal? (This one will likely prompt you for your password first.)
sudo lsof -nP -i -P | grep 5820


Hi Jason,

It sounds there is never a request to http://localhost:5820/admin/users/valid happened, while "Connect" clicked.

And the response of terminal commands you instructed shows:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.