Unable to connect to Stardog-server

I have set up a Stardog-server in a Docker Windows 10 and was successfully able to start it. But when I try to connect to this server from the browser-based studio it gives the following error
"The Stardog Server is not responding. Please check your server status or endpoint."
I switched off my firewall completely and tried to connect but no luck.
It'll be a big help if someone can help me figure this out.
Thank you.

Can you tell us the URLs you are working with, including the protocol (HTTP or HTTPS), for Studio and your Stardog server? For example, are you going to https://stardog.studio and trying to connect to a Stardog server using http://localhost:5820? Depending on your browser, connections from an HTTPS site to an HTTP endpoint will not work, so that's a possible explanation here. To know for sure, we'll need more details.


Hey Jason, thanks for replying!
Yeah so my server URL is - http://localhost:5820
and my studio URL is - Stardog Studio
Both are HTTP only

Okay, thanks. That isn't the issue, then. What is the full command that you are using to start Stardog in Docker? What happens when you go directly to http://localhost:5820 in your browser?


I am actually using the Docker UI to start Startdog, I provide both the locations, in the optional settings (where my stardog license lies and /var/opt/stardog). Getting a "This site cant be reached error. Localhost refused to connect". Attached a screenshot as well

can you share the output of docker container ps

Yep ive attached the outputs as screenshots and some extra info as well

The issue is with how you are starting, port forwarding is not being setup correction. The ps output should look something like

Compare your screenshot with the one above, you will notice the PORTS field is different.

The command to start stardog docker

docker run -it -v ~/stardog-home/:/var/opt/stardog -p 5820:5820 stardog/stardog

If that work you will need to figure our how to pass the arg -p 5820:5820 when starting it from the UI

Hey, running from the command line worked! Thanks a lot :smiley:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.