Stardog-studio from docker

Newbie question: I just want to try Stardog Studio for Docker. I have followed the steps and created a container:

docker run -p 8888:8080 -d stardog/stardog-studio:current

but I am not able to access... http://localhost:8888/ refuses to connect. The actual "" is also refusing to connect.
What can be the source of the issue?

$ docker ps
CONTAINER ID   IMAGE                            COMMAND                  CREATED          STATUS          PORTS                    NAMES
113529c0fc1c   stardog/stardog-studio:current   "/docker-entrypoint.…"   3 seconds ago    Up 2 seconds>8080/tcp   focused_agnesi
64a438d50e5d   stardog/stardog                  "/opt/stardog/bin/st…"   38 minutes ago   Up 38 minutes>5820/tcp   clever_dewdney

$ docker logs 113529c0fc1c
/ /docker-entrypoint.d/ is not empty, will attempt to perform configuration
/ Looking for shell scripts in /docker-entrypoint.d/
/ Launching /docker-entrypoint.d/ info: can not modify /etc/nginx/conf.d/default.conf (read-only file system?)
/ Launching /docker-entrypoint.d/
/ Launching /docker-entrypoint.d/
/ Configuration complete; ready for start up

Hi, try doing a fresh docker pull stardog/stardog-studio:current. I was able to reproduce this behavior with an older image, but once I pulled it down, localhost:8888 worked as intended

Originally I did a pull with v2.2.0 and current (both downloaded the same artifact).

Following your advise, I have now deleted all containers, deleted the image, pulled it again, run it... And still the same error. I guess I should get into the container to find out what the error is, although the commands I can run inside the container are rather limited...

I have restarted the computer and now it seems to work... No idea what was happening...