Connection Refused - Default Settings

Hello!

When connecting to StarDog in StarDog Studio with the default username password and endpoint, I am getting a connection refused message.

Could this be due to my company's firewall my end?

Thanks for the help,

Matt

It could be. Where is Stardog running in relation to Studio?

Thanks for the reply Zachary!

I'm not sure where it is running, I just installed StarDog Studio and clicked "Connect".

Do you know if I am missing a step?

Appreciate the help,

Matt

Are you running Studio in Docker? Is Stardog running on the same machine that you're running Studio or did your company install Stardog somewhere else? If they did they would have to allow access on port 5820 or whatever other port they may have configured it to run on and you'd need to adjust the "Endpoint" setting when connecting.

If you're running it locally, are you sure it's running? What is out output from running stardog-admin server status?

Hey Zachary,

I just downloaded the Windows Stardog+Studio-latest+Installer file from here: Stardog Studio Visualization - Product Page | Stardog and installed and ran it.

I don't have access to Docker in my work environment, so I think I will explore some different solutions.

Thank you for the time and help,

Matt

Hi Matt,

You can install Stardog natively on Windows without Docker. You can find installation instructions in our documentation: Windows Installation | Stardog Documentation 7.5.0

Please let us know if you have any questions or issues.

Cheers,
Noah

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.