Stardog + Gremlin Console: Could not initialize class com.complexible.stardog.gremlin.structure.CachedStardogGraph

Hello, I posted on this forum about two weeks ago regarding a performance issue and found it extremely helpful, so here goes again.

I’m working on integrating Stardog with the Gremlin Console and have run into an error. I am following the guidelines in the manual under the section “Stardog & Gremlin Console” and have successfully created the configuration settings.

I run into problems when I enter the command “graph =” into the Gremlin console. The error I receive says:

“Could not initialize class for com.complexible.stardog.gremlin.structure.CachedStardogGraph”

Upon displaying stack trace, the first two lines look like this:

" at"
" at com.complexible.stardog.gremlin.StardogGraphFactory$ Source)"

Any ideas what the problem could be? Everything worked fine up to this point. I am running Stardog 4.1.1 and TinkerPop 3.2.4, so my first thought was this might be a version issue. Are these two versions compatible, or should I switch to an older version of TinkerPop?

Thanks guys!

UPDATE: Just downloaded/configured TinkerPop 3.0.2-incubating and was able to run this command successfully.

Glad to hear you found the forum so helpful. You also might want to grab the latest Stardog release as well 4.2.3 but keep an eye out for the imminent release of 5.0!

1 Like

My team is planning to update to Stardog 5 when it is released. Just curious, will the new version have compatibility with the latest TinkerPop release?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.