Stardog Studio crashing

(Jason Bourg) #1

Is anyone having an issue with Stardog Studio crashing whenever they click on the workspace icon?

(Jason Rogers) #2

Hi Jason,

Sorry to hear this is happening for you. We haven't heard any other reports of this yet, and aren't experiencing it ourselves. Can you say what version of Studio you're using (you can find this in the "About Stardog Studio" menu item), what version of Stardog itself you're working with, and what operating system you're on?

Thanks,
Jason

(Jason Bourg) #3

Hi Jason,

Thank you for reaching out. Using Stardog Studio v1.6.1 using a macOS Mojave v10.14.4

Here is a step-by-step account of what is happening. greatly appreciate any insight you can provide.

Open Stardog Studio > click connect to Stardog > enter details, click connect, and it connects to the Stardog server > click on workspace icon > click File/Open File > select ttl file on desktop > click Open and it crashes and gives me this message:

Something bad happened! We must have received an unexpected error!
Unfortunately we'll have to restart Studio. Is that okay?

Thank you for your time and help.

-Jason B.

(Jason Bourg) #4

to add...

what's odd is I've done the reverse too. Opened the ttl file, and it loads just fine. Then I connect to the Stardog server and it connects fine. However, when I click on Databases (or any other icon) and try to click on the Workspaces icon, it crashes.

(Jason Rogers) #5

Hi Jason,

Thanks for the additional information. We're still working on a way of reproducing the issue; I followed the steps you listed using the same version of Studio and the same version of macOS, once with a small ttl file and once with a larger (20MB) ttl file, but no crashes occurred.

Here are a few questions that can maybe get us somewhere:

  1. Does this happen with any ttl file, or only with the specific one you've so far been trying to load? Can you share any ttl files with us (either here or by emailing them to me -- my email address is my username here plus @stardog.com)? If you can't share, can you tell us anything about the files, such as the sizes, whether they perhaps contain any special unicode characters, etc.?
  2. Are you connecting to Stardog via an account that has admin permissions, or via a non-admin account? If a non-admin account, do you have access to an admin account that you can try? If so, does trying with the admin account make any difference?
  3. Was your install of Studio a fresh install or an automatic upgrade? Have you used Studio on this machine before?
  4. On macOS, you should have a prefs.json file located at the path ~/Library/Application\ Support/Stardog\ Studio/prefs.json. Does moving that file somewhere else (while Studio is closed) and then starting Studio fix your problem? (When Studio can't locate that file it effectively starts from its initial state, as though you have just installed it.)

Thanks,
Jason

(Jason Bourg) #6

Hi Jason,

Again, thank you. Found a little more detail into my problem. In Stardog Studio (after I connect to the Stardog server) I start off in Workspace. But when I click on either Database or Security and then simply click back to Workspace, it crashes. This is regardless of loading any ttl file at all.

answers to your questions:

  1. happens with any ttl file, but as mentioned, I don't have to even load a file in Workspace for this to even happen.
  2. I'm a non-admin but trying to get set up with an admin account to test this out.
  3. fresh, brand new install. never used on this machine before.
  4. checking on this now..

Thank you,
Jason B.

(Jason Bourg) #7

I do also notice when I'm "connected to Stardog server", when I click on Security, under Users and Roles it just churns (circle) and nothing displays. wondering if it is my connection to our Stardog server..

(Jason Bourg) #8

Hi Jason,

an update on you recommendations.

  1. workplace crashes whenever I navigate off of it and then back on
  2. tried the admin recommendation but no change
  3. uninstalled Stardog Studio and reinstalled but no change
  4. I can't seem to find this file? Would this be under my Stardog Studio install folders?

Again, thank you very much for your time and help!

-Jason B

(Jason Rogers) #9

I can't seem to find this file? Would this be under my Stardog Studio install folders?

You'll typically have to use the terminal (if you weren't already) to find it; it won't show up in Finder, for example, at least by default. If you don't want to use the terminal, then you can make your home folder show up in Finder by opening Finder and going to "Finder" --> "Preferences..." --> "Sidebar" and checking the box next to your home folder (the one with the same name as your user) in the "Show these items in the sidebar:" list. After you do that, you can open your home folder in Finder, then click on "Library," then "Application Support," then "Stardog Studio." The prefs.json file should be inside of that folder.

Thanks,
Jason

(Jason Bourg) #10

Hi Jason,

I actually did do a search via terminal and couldn't find it. Just tried your suggestion in looking under /Library/Application Support but there is no folder or anything listed for Stardog Studio. However, I do have it installed on my local machine.

-Jason B

(Jason Rogers) #11

Just tried your suggestion in looking under /Library/Application Support but there is no folder or anything listed for Stardog Studio

Did you look under /Library/Application Support (which is actually under your root, /, directory) or under [your username here]/Library/Application Support? Folders can exist at both locations, but the Stardog Studio folder specifically will only be in the latter location.

Thanks,
Jason

(Jason Bourg) #12

Hi Jason,

Thank you very much for your help. I just resolved my issue by installing an older version of Stardog Studio (that my team is mostly using) and it seems to have solved my crashing issue.

Again, very greatly appreciate your time and assistance!

Best regards,
Jason Bourg

(Jason Rogers) #13

Glad to hear that you've got something to work with! Can you let us know which version of Stardog Studio you ended up installing? That may at least help us pinpoint any potential issues.

Thanks,
Jason

(Jason Bourg) #14

sure. the older version I'm using is version 1.2.2 (1.2.2.4989)
Again, thanks for the help! -JB

(system) closed #15

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.