Cannot view data in Stardog Explorer


I have created a database in Stardog Studio and used the load data function with my supplied file to add the data. I can query this data in Stardog Studio but when I try to visualise I can see the nodes but there are no classes. For example, if make a SPARQL query for "all instances of a File" I can see an individual and its type "File" but the class does not show in the visualiser.

How I am setting up the data for analysis:
Go to Stardog Studio
Create a database
Select load data - load to stardog:context:default
Add the namespace
Save the database

Previously when I clicked on the "model" option within stardog studio and selected the default settings it would show all my classes, relationships etc but now this does not show.

When I open the database in Stardog Explorer there are no class, relationship or attributes to query and no structure showing so I cannot use the query builder.

I tried mapping the data in Stardog Designer but this returns nothing when selecting default also.

The database shows the correct number of edges for the imported data. When I click on the provenance tab in Studio it says "it seems you do not have enough data in your Knowledge Graph for provenance". This worked previously for this dataset without needing to make changes.

I am unsure what I am doing wrong. Is there something I need to change to get explorer to visualise this data? I couldn't find it in the documentation.

Hi Habat,

this is likely to be related to a change of the default reasoning schema in version 10. You can check out this community post which addresses this issue.

Best regards


Hi Lars,

Thank you for the advice.

I managed to get it working using the advice in the linked community post in your previous message.

1 Like