Create db statement does nothing and shows and error: Invalid file path


  • Windows 10 Professional 64-bits
  • Stardog version 7.9.0
  • STARDOG_HOME=C:\stardog_home
  • PATH=...C:\stardogs\stardog-7.9.0\bin;..
  • java version "1.8.0_331"
  • Java(TM) SE Runtime Environment (build 1.8.0_331-b09)
  • Java HotSpot(TM) 64-Bit Server VM (build 25.331-b09, mixed mode)

Steps to duplicate the issue:
I have followed the install from zip instructions and excecuted the following command on cmd with administrator rights:

stardog-admin server start
It works fine!
Then I open a second elevated command prompt and execute the following command:
stardog-admin db create -n my-database
I get this message in the first command prompt:
Exception in thread "stardog-user-1" Invalid file path
at org.xnio.conduits.Conduits$
at org.xnio.conduits.Conduits$
at Method)
at org.xnio.conduits.Conduits.(
at io.undertow.conduits.DeflatingStreamSinkConduit.writeFinal(
at org.xnio.conduits.ConduitStreamSinkChannel.writeFinal(
at io.undertow.channels.DetachableStreamSinkChannel.writeFinal(
at io.undertow.server.HttpServerExchange$WriteDispatchChannel.writeFinal(
at com.complexible.stardog.protocols.http.server.StardogUndertowErrorHandler.accept(
at com.stardog.http.server.undertow.ErrorHandling.sendErrorResponse(
at com.stardog.http.server.undertow.jaxrs.ExtractRoutes.lambda$handleIt$5(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Caused by: Invalid file path
at org.xnio.conduits.Conduits$
... 22 more
In the second command prompt nothing happens

I have tried to create a db from stargod studio but it stucks while is creating a database.
I have tried with the following environment variables:

  • PATH=...%USERPROFILE%\stardogs\stardog-7.9.0\bin;

I got the same issue

Can you try setting the following environment variable along with STARDOG_HOME


Thanks for you quickly answer
I did it
I've tried using both
STARDOG=C:\stardogs\stardog-7.9.0\ (I think what you sent me was a linux path)
But I'm getting the same issue
Exception in thread "stardog-user-1" Invalid file path ...

Sorry about that. I just missed the drive letter when I copied/pasted your installation path.

I’d double check that the user that you’re running Stardog as has read/write permission to STARDOG_HOME and at least read permission on STARDOG. I’m not a Windows person but I do know Windows has an insane number of DACs so I’m not sure exactly what’s needed.

I’m not convinced that’s what’s the problem here since the error is file not found and not permission denied but it couldn’t hurt to check.

A couple other things I thought of. What do you mean by “elevated” when you said “ I open a second elevated command prompt”?

And another “I don’t think it’s the problem but computers are weird and you never know” type question, what version of Java are you running?

I think the following images answer most of your questions:

Normal cmd
Elevated cmd (Administrator rights)
I've tried with both: normal and elevated cmd

Java version:

Relevant folder or file permissions

Since I have FullControl permission, rest assured.

Note: I've tried with 7.8.3 and 7.9.0 versions.
Definitively is a windows issue. Linux did it well.

Thanks in advance for your help!

Can you send any errors or warnings that you find in stardog.log?

Here you go!
stardog.log (1.8 MB)