Installation StartDog on Windows

I Installed Stardog as described in : Windows Installation | Stardog Documentation Latest

All the steps work perfectly except the last one, when I start the startdog service, I got:
image

I try another way by executing the following command:
Terminal 1(as admin)
1.

C:\stardog\stardog-7.9.1\bin\stardog-admin.bat server start

I got the following:


Terminal 2 (as admin)
So in another command line I execute the command from the folder that includes my data:

C:\stardog\stardog-7.9.1\bin\stardog-admin.bat db create -n myDB data.nt

Now in terminal 1, I got the following exception:

any help please?

Hi Tam,

Can you ensure the file path to your data file is correct? Based on the command you're running you want it to be in your current working directory.

Best,
Clark

Hi ClarkFarley,

Yes I execute the third command from the directory where my data is:


and still I got the same error
Regards

Is a database called "myDB" is being created even though it's not loading the file?

Hi tim,
In the picture above, I try to create a database called myDB and then add data.nt to this database.
Regards

You can try adding the --copy-server-side flag with the stardog-admin db create .... command. I realize that you're running the client and server on the same machine but since you're running it as two separate users Stardog may be having trouble accessing the file. Running as admin doesn't necessarily mean it can access the file. I'm not a Windows person but between windows ACL's and access controls from it possibly being on a separate SMB share mean it's not guaranteed to be able to access it even though it's admin.

Hi Tam,

On top of what @zachary.whitley said, you could try being explicit about the file path too: \stardog\stardog-7.9.1\bin\stardog-admin.bat db create -n myDB \Users\Admin\Documents\dataset\rdf\data.nt

Didn't notice that the file was located in the Admin user directory. That lowers the probability that what I suggested would work but you can give it a try. Are you running both the client and server as admin?

Hi zachary.whitley,

Yes.

Hi stephen,

I get the same exception with this command:
\stardog\stardog-7.9.1\bin\stardog-admin.bat db create -n myDB \Users\Admin\Documents\dataset\rdf\data.nt --copy-server-side
Regards

Even as not an admin is still I get the same exception

no directly we get an exception

This is a wild swing but can you try quoting the full file path?

\stardog\stardog-7.9.1\bin\stardog-admin.bat db create -n myDB "\Users\Admin\Documents\dataset\rdf\data.nt" --copy-server-side

:frowning: unfortunaley still not working

One last one, can you add the drive letter to the path?

\stardog\stardog-7.9.1\bin\stardog-admin.bat db create -n myDB "C:\Users\Admin\Documents\dataset\rdf\data.nt" --copy-server-side

I also tried this option. :frowning:

This looks like an error I was seeing with Oracle's JRE 8u331. I noticed that Oracle had recently released JRE 8u333, so I uninstalled 8u331 and installed the newer version, and Stardog started working on Windows.