Error message during data loading

I got follow error message after data loading failure.

Error [object, Object]

Anyone has idea what caused the error and how to fix it?

A few follow-ups that will help us pinpoint the issue. Some things that would be helpful to know:

  • How are you loading the data - are you using Studio? If so, which version?
  • Which Stardog version are you using?
  • Are you able to share the dataset so we can try to reproduce?
  • Can you share the stardog.log file (or the output of stardog-admin diagnostic report)?
1 Like

What command were you running? What version of stardog and can you share any errors or warnings in stardog.log?

I tried to load a ttl file using stardog Studio. Studio version is 1.12.0.
My stardog version is 7.0.2.
The turtle file size is huge (>3M), I may share a shorter version later.
Stardog diagnostic report file attached.stardog-report-2019-11-02.zip (333.4 KB)

a new error message:
[error] Failed to add data to Dsi-table01. (Error: Illegal predicate value: "0702"^^http://www.w3.org/2001/XMLSchema#integer [L38])

what does this mean?

It isn’t a valid integer with the leading zero. You can either fix up the data or set strict.parsing=false

I figured out the issue.
Some unexpected blanks (" ") got inserted into my ttl file.
After replace them with "_", issue solved. Thanks.

Looks like my previous reply was incorrect. Leading zeros are ok. I should have noticed that it said illegal predicate. I saw the leading zero and assumed that was the problem. That's what I get for shooting from the hip late at night. Glad you figured out the problem.

Glad you were able to get unblocked. If you could share some examples of the rows that gave you issues, that would be helpful - we can work with them on our end and see if we can make the error message more prescriptive.