Infinitely loading data


(Catherine Maria Bromhead) #1

I was adding files to my database, but occasionally stardog studio will hang in the loading phase. Other files load fine, but I'm not sure what to do other than to just shut down the server.


(zachary.whitley) #2

How large of a file are you loading? Is there anything in Stardog.log?


(Catherine Maria Bromhead) #3

It's only 6 kb. I have these errors in my log:

ERROR 2018-10-20 20:16:02,012 [stardog-user-18] com.complexible.stardog.protocols.http.server.StardogHttpServiceLoader:accept(226): An exception was handled by the server: Expected '}', found '<' [line 156]
ERROR 2018-10-20 20:16:02,019 [stardog-user-19] com.complexible.stardog.protocols.http.server.StardogHttpServiceLoader:accept(229): An unexpected exception was handled by the server
com.complexible.stardog.server.UnknownTransactionException: 8109a72f-ebb3-4ae8-adcc-452a9460d57f is not a known transaction.
at com.complexible.stardog.db.DatabaseImpl.openConnection(DatabaseImpl.java:1093) ~[stardog-5.3.5.jar:?]
at com.complexible.stardog.StardogKernel.getConnection(StardogKernel.java:1196) ~[stardog-5.3.5.jar:?]
at com.complexible.stardog.protocols.http.server.TransactionService.rollback(TransactionService.java:152) ~[stardog-protocols-http-server-5.3.5.jar:?]
at com.stardog.http.server.undertow.jaxrs.ExtractRoutes.lambda$handleIt$5(ExtractRoutes.java:192) ~[stardog-protocols-http-server-5.3.5.jar:?]
at org.apache.shiro.subject.support.SubjectRunnable.doRun(SubjectRunnable.java:120) [shiro-core-1.3.0.jar:1.3.0]
at org.apache.shiro.subject.support.SubjectRunnable.run(SubjectRunnable.java:108) [shiro-core-1.3.0.jar:1.3.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_191]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_191]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_191]


(zachary.whitley) #4

Can you share the data and the command you’re using to load it?


(Catherine Maria Bromhead) #5

I was doing it through stardog studio. I haven't been able how to load data into it through commands, the ones for Linux don't work for Windows. Here is the file.

de_causis_quibus_exules_aquilonensium_ad_muminenses_adducti_sunt.trig (5.8 KB)


(zachary.whitley) #6

There should be equivalent commands for Windows with a .bat extension. They should work. What is the problem you’re having with them?


(Catherine Maria Bromhead) #7

I agree, I just can't figure out what they are. This is the command I am trying to run to do a bulk load:
c:\data\stardog>bin\stardog data add irish-gen-named earlyIrishRelationship.ttl earlyIrishTitles.ttl oldIrishOntology.ttl ../rel-vocab-20100607.rdf ../foaf.rdf ../dcterms.rdf ../dctype.rdf ../prov.rdf ./LL/.trig ./Rawl_B502/.trig ./Duanaire_Finn/.trig ./NLS.Adv.72.1.1/.trig ./LU/*.trig

The problem I get is that it says Illegal char <*>


(zachary.whitley) #8

I think you’ve got a parse error in there. Not sure why it’s hanging though. Give me a sec and I’ll see if I can find it.


(Catherine Maria Bromhead) #9

I just want to reiterate that the infinite loading thing was happening in stardog studio. My problem with the command is that it won't run due to the illegal character thing.


(zachary.whitley) #10

Looks like you were missing a couple of periods. Give this a try

de_causis_quibus_exules_aquilonensium_ad_muminenses_adducti_sunt.trig (5.8 KB)


(Catherine Maria Bromhead) #11

That helped, thanks. Any suggestions for the command line?


(Catherine Maria Bromhead) #12

I also tried doing this in Cygwin but I get the same problem.


(zachary.whitley) #13

Glad to hear that helped. Can you tell me what’s happening when you run the command from the command line? Do you get nothing back? Errors? Warnings? Are you running the .bat commands from cod.exe or the bash commands from cygwin?


(Catherine Maria Bromhead) #14

I was running cmd when I got this error, but I got it later with Cygwin as well. When I entered the command into cmd, I get a message that says illegal char <*>. I eventually fixed it in Cygwin but it required moving all of my files into different folders. I am unsure why it wasn't working initially. My thought was that windows didn't recognize the * as a wildcard, but with the Cygwin error I'm not so sure.


(zachary.whitley) #15

It’s though to tell without knowing what exact command you’re running but my best guess is that you’re using * as a command line argument that isn’t being expanded by windows and is being passed along. The files doen’t have base defined and it is creating an illegal url <*>


(Catherine Maria Bromhead) #16

I posted the command above yesterday. It's

c:\data\stardog>bin\stardog data add myDB earlyIrishRelationship.ttl earlyIrishTitles.ttl oldIrishOntology.ttl ../rel-vocab-20100607.rdf ../foaf.rdf ../dcterms.rdf ../dctype.rdf ../prov.rdf ./LL/ *.trig ./Rawl_B502/* .trig ./Duanaire_Finn/ *.trig ./NLS.Adv.72.1.1/* .trig ./LU/*.trig


(zachary.whitley) #17

You appear to be running this in cmd.exe so you need to run the bat scripts with the .bat extension. If this was copy & pasted there are some spaces between your paths and *.trig which might be causing problems.

I know ms has been playing with using bash in windows so I don't know what Windows would do these days if you tried to execute a bash script these days but you would probably have better luck with the bat files anyway.


(Catherine Maria Bromhead) #18

Sorry, I'm not sure what you mean in terms of using the bat scripts. I'm pretty new to this stuff. And as for the spaces, I'm copying from my post above which seems to have added spaces in, but when I wrote the command out in cmd I made sure not to put any spaces.


(stephen) #19

In windows 10 at least, I don't think you strictly have to put the .bat extension. Windows ought to see stardog.bat and use it versus the bash script.

The other thing I can see is that your paths to the files have forward slashes in them (/) whereas windows requires backslashes () in paths. ..\dcterms.rdf, .\LL\*.trig, etc.


(Catherine Maria Bromhead) #20

yeah it's possible the backslashes needed to be used, not sure. I managed to figure it out in Cygwin, although it was giving me the same error at first. I had to move all the files to a new directory in my stardog folder for it to work, not sure why it worked but it did.