How to recover after a "No space left on device" error


After running some tests with a Free Cloud instance, it seems I surpassed the quota of data I can use (I get a "no space left on device error"). I have been trying to drop the database from Studio and, although I was getting the same error during the drop, the databases are apparently gone.

However, i am unable to create any new database, with an error rmessage indicating I still have 3 databases in the instance (even if per Studio I have none)

Question: Is there any way to get this cloud instance operational again? I do not mind about the actual data, but just about being able to resume the test with a new DB

Thank you

Please try again. We fixed a configuration setting, so you should be good to go now.

I'm having a similar problem. When I try to drop a database, I get the following error message:

Database "bsn_test" could not be dropped: 000012: IO error: Error allocating space to file : /var/opt/stardog/data/009060.sstError : No space left on device

Hi Henrik, we looked into you instance and have restarted it. Please have another try.

1 Like

Hello everyone, I unfortunately also got the same error message when trying to remove data from the database:

Failed to remove data from "FDD_NEW": IO error: No space left on device: While appending to file: /var/opt/stardog/data/000188.log: No space left on device

When I try to delete the whole database instead I get this:

Database "FDD_NEW" could not be dropped: 000012: There was an error while deleting 'FDD_NEW'

Could it be restarted like the other ones in this topic?

I maybe need to drop it again some more times while testing my ontology, is it likely that this error will happen more frequently?

Thank you so much for your help!

Hi @hannah_g I have resolved this issue on your instance and you should be good to go now.