Mismatched and unknown MySQL data source getting created for elastic search URL in properties file

Hi Team,
Trying to create virtual graph from elasticsearch as a data source

When i tried to create a elastic search data source with the following command and property file, MYSQL data source is getting created instead of elasticsearch.

stardog-admin data-source add var/opt/stardog/tutorial-content/elastic-vkg/elkl.properties

getting "Successfully added data source elkl" message in console, but different MYSQL data source is getting created.



ipaddress => ip of a host running elastic search, with no authentications required to it.

Could anybody Please advice if i'm missing something ?

Note : Elastic data source is working if i create it through Stardog studio, but not happening with cmd line statements


Can you please share how you are accessing Stardog Studio (e.g. http://stardog.studio or using Docker)? A relevant bug was fixed in Studio v2.3.1 - see VET-1034 in the Studio Release Notes.

To resolve the behavior in the interim, can you please try refreshing Studio, logging out, and logging back in to see if Elasticsearch is listed in your data source list.


1 Like

Thank you . this worked

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.