Not able to install Stardog and set paths

HI,

I am very new to stardog.

Your instructions for setting stardog_home and stardog version are just confusing.

I had downloaded the stardog-7.4.0 zip and extracted it to my home path.

Please help me understand how do I start running stardog admin server. I am using ubuntu 18.04 os.

Please give me clear steps using the paths.

I am getting error as below when I type ./stardog-admin in my terminal

Unrecognized option: --add-opens
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

when I explored it says we need to use the 64 bit jdk.

when I check java -version it gives :

openjdk version "11.0.8" 2020-07-14
OpenJDK Runtime Environment (build 11.0.8+10-post-Ubuntu-0ubuntu118.04.1)
OpenJDK 64-Bit Server VM (build 11.0.8+10-post-Ubuntu-0ubuntu118.04.1, mixed mode, sharing)

Thanks
Kavitha

1 Like

try this and see what's happen ?

./stardog-admin server start

I am getting the same error even after typing this:

./stardog-admin server start

Unrecognized option: --add-opens
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

The --add-opens error is an option for the jvm. It was added in java 9 with the caveat that it would be removed in the future and this may be causing the problem. Stardog should support your OS and Java version.

There is a possibility that Stardog is getting confused about what exact jre you're running and that you're actually running java 8 but Stardog thinks you're running 11.

What do you get when you run echo $JAVA_HOME?

Thanks for your reply.

The issue got resolved when I uninstall the Openjdk 11.0.8 (link to uninstall: https://novicestuffs.wordpress.com/2017/04/25/how-to-uninstall-java-from-linux/)

But I dont' understand when stardog supports both the java8 and java 11, why did not it worked before uninstalling 11.0.8.

Now i have the below in my machine.
java version "1.8.0_112"
Java(TM) SE Runtime Environment (build 1.8.0_112-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.112-b15, mixed mode)

I can start the stardog admin server using the
./stardog-admin server start --home /home/users/STARDOG_HOME

It drived me to get the license-key.bin.

NOW THE PROBLEM IS WITH LICENSE KEY:

I kept the license key in my STARDOG_HOME directory.

When I again open terminal and go the path

~/stardog-7.4.0/bin$ ./stardog-admin server start

it again says that valid license key is not present in bin ( but I moved this in to my STARDOG_HOME).

Please help me understand if I have to copy/move the license-key.bin from stardog-7.4.0/bin to STARDOG_HOME.

and Do I need to get a licence every time when I try to start the server.

Thanks
Kavitha

Hi Kavitha,

You need to place your stardog license key in the Stardog_Home directory itself but not in the bin directory.

Note : Stardog Server license key is valid for around 60 Days, so you need to get (generate) license key every time when you run the server.

Do the following steps :

  1. Configure the environment variable "path" with Stardog_Home/bin folder. So that you can execute the command [./stardog-admin server start] from any directory
  2. Execute the command [./stardog-admin server start] from Stardog_Home directory where the license is present

Hope it should resolve your issue

Regards,
Omkar Thadem

Thank you.

Btw, I really dont understand how this STARDOG_HOME works here.

I have stardog-7.4.0 in my home path from where I can see the server-admin command in bin folder.

If I give the command in my terminal like below:

/home/user/stardog-7.4.0/bin$ ./stardog-admin server start

will start my stardog server.

Please help me understand how can I give the same command from STARDOG_HOME where there is no server-admin.

i.e, if i try to start server-admin from

/home/user/STARDOG_HOME$ ./stardog-admin server start

I am getting an error as stardog-admin command not found.

how can "stardog-admin" will be present in my STARDOG_HOME ?

and

If I set the path as mentioned in your reply "path: Stardog_Home/bin" and try to start server it throws error as "there is no valid license available", because it is present in STARDOG_HOME directory.

Totally Confused.

Thanks
Kavitha

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.