One database that I can see

I seem to have only one database, as below (in Stardog Studio):

From Stardog Designer I'm publishing a model as follows:

When I hit publish, selecting the DB, go back to Stardog Studio and refresh and select the published model nothing is there?

In the "Provenance" panel, the classes show but the data doesn't:

No doubt I'm doing something wrong but am a bit lost. Can anyone advise this newbe?

Before everything ceased working I did get an out of memory message, perhaps the instance needs to be restarted?


Hi Marcus,

I want to make sure I understand you right. Are you saying when you go to the Models tab (two below Provenance) and select your DB, you don't see the model you published from Designer?

Your third screenshot shows the Workspace tab. The empty area you point out shows any stored queries you might have, not the model you published. Assuming you don't have any stored queries for this database, this area should be empty.

If your model did get published to the database correctly though, you should be able to select the model as a named graph on the Workspace tab. You can select a named graph by clicking on the stack of three squares to the left of the magnifying glass.

If you're still not seeing your model in the places I mentioned though, we can certainly restart your instance.


Hi Steve,
Thanks for responding. I managed to reconstitute everything and its working. I suspect the problem was with me. Once I dropped the DB, logged out, logged back in, and republished the model it worked.


Best regards,

1 Like