Querying not working when trying to reproduce Modeling training music results


I'm trying to import the data and schema from the Modeling training (Trainings - Modeling | Stardog with data and schema from stardog-tutorials/music at master · stardog-union/stardog-tutorials · GitHub) to get the same results, and I seem to successfully import the data and schema however when I trying querying I don't get any results. I think I'm missing a step but not sure what, these are the steps I have taken:

  1. Created a DB and imported music.ttl (from stardog-tutorials/music at master · stardog-union/stardog-tutorials · GitHub), put into the default graph
  2. Imported the schema - music_schema.ttl (also from github) into a new named graph.
  3. In Models I create a new named model which the schema should appear in
  4. This is all good, where I can see the data is in the default model and the schema is in the named model (viewed in Models tab)
  5. In Workspace I try to do a basic query (list all albums) which works fine for the original stardog-tutorial-music database but when I run it on my own database it does not give any results.

I also tried loading the schema into the default graph as well but this made no difference.
Any help would be greatly appreciated! Thank you

Fixed now, the issue was that I hadn't realised the namespaces used in the tutorials were different from the default namespaces, so I had to adjust the namespace for the empty prefix (like shown in this post How to define namespace for your tutorial Album class) to the tutorial one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.