Stardog-admin: line 153: 4503 killed:9


I got this error when I ran stardog-admin server start after the installation through Homebrew in macOS 11.1 (Big Sur), MacBook Pro Early 2015:

Last login: Wed Jan 27 15:27:05 on ttys000
 ~ % stardog-admin server start
STARDOG_HOME '/var/stardog/' is not writeable by the current user
 ~ % sudo stardog-admin server start
Thank you for downloading Stardog.
A valid license was not found in /Users/xxx.
Would you like to download a trial license from Stardog (y/N)? y
Contacting Stardog..............
NOTE: By downloading a Stardog license you agree to be bound by our evaluation agreement.
This agreement can be found at

Do you agree to these terms (y/N)?  y
Are you interested in requesting an academic trial license (y/N)?  y
Please provide a valid academic email address to start your 365-day trial:
Contacting license server.................
We may occasionally contact you with Stardog learning and training resources. Do you wish to receive this content (y/N)?  y
Contacting license server....
Email validated. You now have a 365-day Stardog trial license. Starting Stardog...
/usr/local/bin/stardog-admin: line 153:  4358 Killed: 9               "java" -Dstardog.home=/Users/xxx/ -Xmx2g -Xms2g -XX:MaxDirectMemorySize=1500m -Djava.library.path=/usr/local/Cellar/stardog/7.4.5/bin/../lib -XX:SoftRefLRUPolicyMSPerMB=1 -XX:+UseParallelOldGC -XX:+UseCompressedOops -Djavax.xml.datatype.DatatypeFactory=org.apache.xerces.jaxp.datatype.DatatypeFactoryImpl -Dapple.awt.UIElement=true -Dfile.encoding=UTF-8 -Dlog4j.configurationFile=/usr/local/Cellar/stardog/7.4.5/bin/../server/dbms/log4j2.xml -Dstardog.install.location=/usr/local/Cellar/stardog/7.4.5/bin/.. -server -classpath /usr/local/Cellar/stardog/7.4.5/bin/../client/ext/*:/usr/local/Cellar/stardog/7.4.5/bin/../client/api/*:/usr/local/Cellar/stardog/7.4.5/bin/../client/cli/*:/usr/local/Cellar/stardog/7.4.5/bin/../client/http/*:/usr/local/Cellar/stardog/7.4.5/bin/../client/pack/*:/usr/local/Cellar/stardog/7.4.5/bin/../server/ext/*:/usr/local/Cellar/stardog/7.4.5/bin/../server/dbms/*:/* com.complexible.stardog.cli.admin.CLI server start >> /Users/leroy//stardog.log 2>&1

How can I fix this?


Have you fixed this? I have the same error.

Are you able to use Stardog any amount of time before it is killed?

No, I got this error directly after I ran 'stardog-admin server start'

Is there stardog.log file there? Might you share it here? Have you attempted starting it again?

From stardog.log: "Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option UseParallelOldGC; support was removed in 15.0"

I have restarted several times, tried different methods, changed Java from "Java SE 15.0.2" to "Java SE 8", but still experienced the same issue.

"java" -Dstardog.home=..../stardog-7.5.1/bin/ -Xmx2g -Xms2g -XX:MaxDirectMemorySize=1500m -Djava.library.path=/usr/local/Cellar/stardog/7.5.1/bin/../lib -XX:SoftRefLRUPolicyMSPerMB=1 -XX:+UseParallelOldGC -XX:+UseCompressedOops -Djavax.xml.datatype.DatatypeFactory=org.apache.xerces.jaxp.datatype.DatatypeFactoryImpl -Dapple.awt.UIElement=true -Dfile.encoding=UTF-8 --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.nio=ALL-UNNAMED --add-opens java.base/java.util.concurrent.atomic=ALL-UNNAMED --add-opens java.base/ --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED --add-opens=java.base/jdk.internal.misc=ALL-UNNAMED -Djdk.tls.client.protocols=TLSv1.2 -Dlog4j.configurationFile=/usr/local/Cellar/stardog/7.5.1/bin/../server/dbms/log4j2.xml -Dstardog.install.location=/usr/local/Cellar/stardog/7.5.1/bin/.. -server -classpath /usr/local/Cellar/stardog/7.5.1/bin/../client/ext/:/usr/local/Cellar/stardog/7.5.1/bin/../client/api/:/usr/local/Cellar/stardog/7.5.1/bin/../client/cli/:/usr/local/Cellar/stardog/7.5.1/bin/../client/http/:/usr/local/Cellar/stardog/7.5.1/bin/../client/pack/:/usr/local/Cellar/stardog/7.5.1/bin/../server/ext/:/usr/local/Cellar/stardog/7.5.1/bin/../server/dbms/:confused: com.complexible.stardog.cli.admin.CLI server start >> ..../stardog/stardog-7.5.1/bin//stardog.log 2>&1

I can confirm the same thing is happening on my laptop running Catalina with the following versions of java: java8, java11, openjdk8 and openjdk11.

As a workaround, I started stardog in a docker container which is easy to install. I will see if I can reproduce on my second laptop also running Catalina later this week.


I was able to successfully install Stardog on Catalina using brew this weekend running java8. Maybe it's something other than just os/jvm

I installed it on my second laptop running Catalina without any issue. Still have not figured out why it does not work on the first one yet thought.

-Serge @Annie_Yu have you gotten it to work. If no, there are three workaround that you can use

#1 install manually from zip
Just follow the instruction for curl found @ Get Started with Stardog - Get Started Page | Stardog

#2 use docker

Install docker and follow the instruction for docker found @ Get Started with Stardog - Get Started Page | Stardog

#3 fix the homebrew installation

I put this option last as it a bespoke temporary solution. The first two are fully supported and well documented. But for the curious and at your own risk

I was able to fix my homebrew installation. I found that brew modifies dylib post install when it installs a package. This is somehow corrupting them and causing the library linker process to fail.

I don't fully understand why and still investigating, but I was able to fix my homebrew installation with the following commands

  1. download zip as in option #1
  2. unzip
  3. sudo cp stardog-7.6.0/lib/*dylib /usr/local/Cellar/stardog/7.6.0/lib
  4. clean up

After that it work as expected.

Having said that, I recommend you use option #1 or 2.

If anyone reading this are expert with homebrew and Apple's install_tool_name command, please feel free to chip in.