Create DB: not allowed

Hi everyone,

When I try to create a DB in Studio it prompts <...: not allowed>, the same occurs when trying to create the tutorial DB. Any help?

Many thanks,


Can you describe your Stardog installation and management a bit.? Are you running Stardog yourself on your local machine or was it setup by someone else and is centrally managed by your IT team?

The first thing I'm thinking is that someone didn't give you permission to create databases. If it's centrally managed I would consult with IT at check that you have the required permissions.

Hi Zachary,

I installed it myself via terminal and I'm running it via Docker. I can create a DB in the console, but it's not working in Studio?!
Thanks :slight_smile:

I'm still thinking it's a permission problem but at least now you don't have to ask someone else to fix it. You are in control of your own destiny!

I'm assuming you can connect to Stardog and you get the little green connection dot icon with a lightning bolt in it. Have you setup any new users or are you just connecting with the defaults as admin?

You're using the same user in Studio that you're using in the CLI? Are you running Stardog or Studio or both in Docker?

Have you ever been able to create a database or is this the first time you've connected and you've never been able to create one?

That's correct, indeed. But such freedom comes with A LOT of questions :wink:
So, I'm using a different username to connect to Studio via Docker, as I'm running Stardog in the CLI just as an admin

I was able to create a DB in the CLI, but have never been able to do so in Studio

Many thanks for your help!

Can you create a database if you connect as admin with Studio?

No it won't let me.
So I've just tried to create a new DB in CLI, and this works fine.
Could it be a port issue? CLI is listening to :5820, and when I followed the instructions for the Docker set-up I set the Docker port to :6464?
Please find two images attached...

Screenshot 2020-06-23 at 15.31.54

Screenshot 2020-06-23 at 15.26.58

Now I’m really confused. It looks like it’s successfully connected but I can’t tell to what it’s connected.

I had asked previously but the answer wasn’t clear. Stardog and Studio, which ones, or both are running in Docker?

Apologies for not having been clear.
So, I think the easiest way is to explain all my steps:
In the CLI:
I'm launching Stardog via <stardog-admin server start> and then I'm firing up Studio via Docker with in the CLI and switch to my set localhost port
It then lets me connect just fine, so this is all working, but it won't allow me to set up a DB in Studio

I hope this was understandable now :blush:

So, I just switched to another browser and it all runs fine in Chrome. Many thanks for your help, and silly me should have tried that earlier -.-

Is there a browser pref for Stardog?

What browser and OS were you using?

Stardog recommends the latest version of either Firefox or Chrome.

Safari and Catalina 10.15.5