Facing Issues while using Stardog for Unix (AWS EC2) (Version 7.4.2)

Hello Stardog,

I am currently working with Stardog for Unix version 7.4.2 in my AWS EC2 Server and I am facing the below-provided couple of issues with the same-

1. When I stop and start the Stardog server the previously created databases seem to be deleted and upon starting it back it is asking for details all over again, like the mail details and various confirmations (As it asks while starting the server the first time after installation). Felt like the server got reset altogether.
I installed Stardog in AWS EC2 following the instructions as provided in the official manual of Stardog. Link as per below-

Amazon EC2

2. I tried to create a virtual graph from a mapping SMS file connecting my AWS Aurora (My SQL) but while creating, I encountered a driver load issue. The screenshot of the issue is provided below.

P.S.- I have also explored Stardog for Windows Version 7.4.1 and 7.4.2 and I did not get the issue in there.

Any help would be greatly appreciated!

Hi Ashique,

Re: #1: Stardog stores data in a "home directory". The home directory can be set using the STARDOG_HOME environment variable. If this is not set, which I'm assuming it's not in your case, Stardog will use the current directory as the home directory. This means if you start Stardog from a different directory next time, the home directory will be different and the previously stored data will not be visible.

Re: #2: This looks ok to me. I wonder if there's problem with both of those jar files. Can you remove the one without the -bin component and try again?

#1 This might also be a permission problem. If you tried starting the stardog daemon with a different user than the systemd scripts use than it might not be able to read the license when you start it with systemd.

I haven't tried an rpm install in a while but the docs might need a small update. I think the instructions may have been written before the automatic license fetching where you manually placed the license file.

#2 This also might be a permission problem. Depending on how you installed Stardog it might not be running as user ec2-user and you might not have read access to the /opt/stardog/ext directory.

Hi Jess,

Thanks for looking into this. Yes, you were right regarding issue #1, it was silly from my end to miss out on setting the STARDOG_HOME. After I set the issue got solved.

However, issue #2 persists, I removed -bin component but it did not solve. I downloaded the jar from MySQL official page as per provided in the Stardog Manual-

Stardog Manual: https://www.stardog.com/docs/#_supported_client_drivers
MySQL URL: https://dev.mysql.com/downloads/connector/j/5.1.html

Also to mention, In Stardog for Windows version, I could create the Virtual Graph connecting Aurora with the very same platform-independent jar file.

Thanks Whitley for replying.
Regarding #2 I had this apprehension of not having write/executable access in /opt/stardog when I faced the issue first time. So, I tried creating a folder /ext in my EC2 home (/home/ec2-user) and then export the path in STARDOG_EXT but unfortunately that did not work. I have write and execute permission in EC2 home path.

Can you share the log file from the server? It will include the stack trace which aids in analyzing the cause of the error. Thanks.

Jess

Sure. Attached.

stardog.log (18.0 KB)

We can troubleshoot the environment issue. But perhaps it would be easier for now to just copy the jar to /opt/stardog/server/dbms.

A few notes:

  • Did you use export when setting variable? eg export STARDOG_EXT=/opt/stardog/ext
    • If not, the variable will only be visible in the current process/shell and not inherited by Stardog when started.
  • Are you calling stardog-admin server start directly? If so, I believe you should be using systemd to manage the package when installed in this manner, eg systemctl start stardog

After copying the jar file into /opt/stardog/server/dbms the jar is working fine. I can now create the Virtual Graph. :smile:

However, below are the response to your notes-

  • I did export the path of the jar directory using the command export STARDOG_EXT=/opt/stardog/ext and keeping the jar file in the path- /opt/stardog/ext. But the issue still persisted.
  • sudo systemctl start stardog is not working (as attached). I have tried installing /etc/stardog.env.sh file bit did not work. I had to use sudo ./stardog-admin server start from the /bin/.

Can you run journalctl -u stardog.service and send the output?

Sure Zachary,
Attached.
journalctl_output.log (5.6 KB)