License for stardog

Hi Team,

We are facing issue in fetching stardog license for windows 10 machine. while requesting from command prompt, it asks for an email id and says email address is undeliverable.

Please help!
Thank you!

Hi Smrati,

Sorry for the trouble here. Can you share the email address you are using so we can look into why it's getting rejected? If you'd prefer not to post it publicly, you can send it to me in a private message.
Simon

Hi Simon: thank you so much. I could get the key now. But it is throwing another error:
An unexpected error occurred.
java.lang.UnsatisfiedLinkError: no Starrocks in java.library.path

Kindly let me know how to resolve this.
Thank you!

Are you running it from within the stardog-7.0.x directory? If not you'll need to set the STARDOG_HOME env variable to your installation directory.

STARDOG_HOME is set to path where the license is saved. Stardog installation is in a different directory. That is how earlier versions used to work, right?
I would like to apologize if i am missing out on something.

Please let me know if STARDOG_HOME has to be inside the installation itself!

Thank you!

No need to appologize, things have changed a little bit with the 7 release and I'm happy to help out. First, I assumed you're trying to get 7.x running since you mentioned you were having problems downloading the license. Please correct me if that is not the case.

I haven't personally run 7 on windows so I'm not quite sure about the details there. I'm not positive that it's still supported to run directly on Windows and the preferred way may now be to run it on Windows under docker. I'm not positive about that though because the Windows .bat files are still in the ./bin directory. The license should be located in the STARDOG_HOME directory which would also be the stardog distribution directory .

STARDOG_HOME does not need to be the installation directory (we still discourage this), however there should be a JVM setting: -Djava.library.path=/path/to/stardog/lib. The .sh/.bat scripts ought to set that, but in cases where it doesn't quite get it right, you'll want to set that in your STARDOG_JAVA_ARGS env variable.

Setting STARDOG_HOME was the "quick start" way. A better recommendation is to set STARDOG_HOME to where you'll be storing your databases and STARDOG to your installation directory.

I was guessing that java.library.path wasn't getting set correctly because STARDOG_HOME wasn't set and it was defaulting to the CWD

I had issues. But those were replied after resolution by Stardog team. Thank you for that! :slight_smile:
I am trying to run 7.0.1 on windows without docker.
I have set STARDOG_HOME to the directory where license is and where I want to store the databases.
I tried setting STARDOG_JAVA_ARGS to stardog7.0.1/lib folder . but then I am facing
Error: Could not find or load main class at

Please let me know in case I have set the wrong path or if anything else is required.
Thank you!

I would unset STARDOG_JAVA_ARGS for now and try setting and env variable STARDOG to your installation forlder. The folder created after unziping the distribution stardog-latest.zip

Stardog 7 currently does NOT run natively in Windows. You will need to use the docker image or some other virtual environment.

I got license on the machine on which i am installing stardog. On pulling stardog, I am getting this error:
latest: Pulling from stardog
image operating system "linux" cannot be used on this platform

Please let me know what should be done in this error.

Thank you!

You need to switch from using native windows containers to linux containers. See this for details https://docs.docker.com/docker-for-windows/#switch-between-windows-and-linux-containers

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.