New Windows 10 install - localhost refuses to connect

Hello

I'm new to stardog and docker and cannot access the server on port 5820 after following the install instructions on Windows 10 Enterprise.

Quick assistance would be much appreciated as we're trying to trial stardog on a project with a deadline.

To begin I can't find any Windows specific install instructions, but I assume we're supposed to follow the steps at: Home | Stardog Documentation 7.8.0.

I had to replace the linux home directory, which also was not explicitly stated for Windows users e.g.:

docker run -it -v c:\stardog-home:/var/opt/stardog stardog/stardog

After running the command the trial license was downloaded and the server states its running on port 5820.

However I cannot connect to the server via a browser on my local machine i.e. http://localhost:5820.

I have disabled Windows Firewall so that cannot be the problem.

I've checked for related topics but nothing has been helpful.

As suggested in the topic below I did try adding a parameter to the above command to specify hyper-v isolation but it fails with this error:

docker: Error response from daemon: Invalid isolation: "hyperv" - linux only supports 'default'.

Hi Aaron,

You will want to include -p 5820:5820 in your docker run command to bind port 5820 locally to port 5820 on the container, which is where the server is listening.

Hi Stephen

Thanks for the quick response. After adding that parameter I get an http authentication dialog, however I cannot authenticate.

I've tried the default admin/admin as per the instructions and that results in a 404.

Also tried creating a .sdpass password file as per instructions and the dialog but the credentials I added are rejected.

Re: "on a Windows system, it will look for sdpass.conf in Application Data\stardog" that file does not exist on my system, however as I'm running a linux docker container I would assume this file would not be required.

Needless to say this is a very frustrating way to start a trial of what looks like a great product.

What version of Stardog are you trying to run? The web console has been deprecated and removed. I'm asking because you mentioned an, "authentication dialog" and wanted to clarify so we can get you up and running as quickly as possible. The preferred way to connect would be either the Stardog cli or via Stardog studio. Can you connect with either of these methods?

Can you include the exact steps you're taking and the commands you're running?

localhost:5820 will give you 404, but you should able to connect using stardog studio.

Even though in stardog 7, you will not able to connect webconsole, but you still able to get some response by hitting below url:
localhost:5820/mydb (mydb created from stardog studio or console) you will able to see the data stored in the your database

I just checked 7.1.2 to see what you were getting. I hadn't tried connecting with a web browser since they got rid of the web console so I wasn't sure what the expected response would be. I got an authentication dialog and the 404 response that you got. Stardog should be up and running and you should be able to connect successfully to it with Stardog Studio. You can get a copy of Studio from here https://www.stardog.com/studio/

Thanks for the quick responses all.

After adding the -p 5820:5820 switch Studio does indeed connect to the server with admin/admin.

But one would assume the server endpoint http://localhost:5820 would at least return a status page to verify it's working.

Incidentally our organisation has been trying to contact Stardog since Monday. It's now Wednesday and we've had no response, which is not reassuring. We need to clarify pricing and support available for our requirements. Does anyone have experience contacting the company, are they having difficulties?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.