Stardog white page

Hi all,
Here is my problem, when stardog server is running the local host page age is blank!
It seams that something does not let it to pop up.
I had it earlier but it is not working now.
It is now asking for “java security” so I can not say yes.
On my friend’s system it works great but not in mine.
Use to be it was working on my system as well.

What version of Stardog are you running? What OS are you runnong on? What browser are you using? Can you elaborate on, " it’s asking for “java security”"?

Thanks for reply.
I am using stardog 5.0.2. OS is windows 10.
I check it with all browser including IE, Firefox, Safari,Chrome and all of them are up-to-date
Previously I saw a dialogue box “java security” when it was working but now I am not asked for that dialog box anymore and as a result the web-page is blank!

I won’t have access to a machine running 5.0.2 until I get home tonight so until then I can only make some suggestions that you might try. I can only guess that the “java security” was the login dialog. If you dismissed it perhaps something got into a bad state. You can try refreshing the browser cache - althought I doubt that’s it because it wouldn’t have been a problem when you went to try a different browser. You can also try shutting down Stardog and restarting. I don’t normally use windows but you might want to look at any firewall settings and if there are any errors in the browser javascript console and/or in stardog.logs on the server side.

No.The log in dialogue is showing and I submit it.
I am talking about another dialogue which is a system dialogue about security risk with java content.

Ah. I think you need to adjust your Java security settings https://www.java.com/en/download/help/jcp_security.xml

I checked that couple of times, Still no progress

It looks like you might need to set deployment.security.level=MEDIUM in the deployment.properties file for your JRE. The MEDIUM option was removed from the control panel in Java 8. I’m not sure if it was just removed from the GUI but will still be honored in the deployment.properties or if it isn’t supported at all anymore.

Here is the Oracle docs for 7

http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/jcp/properties.html

(I thought these setttings were just for java applets downloaded from the web and didn’t think that the Stardog webconsole used anything like that but maybe I’m incorrect about it only being applets or that Stardog doesn’t use them)

Thanks again.
I still have the same problem.

What URL have you entered into the web browser?

the server is working and the address is right(which is localhost:5820).
I can see stardog links but I could not see the panel.
It even asks for admin and pass.
But no admin panel.

Is there any chance you can include a screenshot?

Problem resolved.
My java had some bugs
Thank for all the support.
It is really great to have people like you.

I am having the same problem. How did you solve it ? What java problem did you have and solved ?

I already replied it on your post.
The cause of the problem is “windows Firewall” blocks “java”.
Go and active your java both on “private” and “public” access in firewall setting.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.