Dear all, I have run into a few issues getting Studio to talk to my server. Stardog is running on an aws ec2 instance server running Ubuntu 20.04 and is merrily populated with data.

I want to use online Studio to connect over https to the server. I have opened the port in aws with tcp protocol to 5820, but have many problems.

First, the ssl setup is failing with a cannot load key when I invoke stardog with require-ssl. I followed the exact setup details in the docs and generated trust and key store jks files.
I then put these in my stardog file and exported the java args in my environment.

I have tried setting and unsetting the ssl protocols to be different tls versions, 1.0 1.1, 1.2 and 1.3 which produces handshake errors. When tls version is unset, the key cannot be recovered. Is it better to use pkcs12 formatted keys?

Finally, I'm not sure how we can import security certificates into Studio Online since the advanced tab does not have this option at login.

All advice and options gladly received.

Replying to my own issues with what I found:

  1. Setup with ssl now works, however, 2 steps necessary:

First. no shell escapes in password entries. A dash character was enough to cause a problem even with single quotes.

Second, in delete the key type variable javax. net. ssl. keyStoreType. I put mine to jks format which failed. Then tried pkcs12 which also failed. Unset it works.

Third when you've done all this and server is invoked successfully as https you may get the error that the host name is not matched in the keystore. This requires a reset up adding in the - ext flag which specifies the host name to the keystores.

eg: keytool -ext should fix the issue.

Hope this helps anyone with similar issues

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.